Tool change mid project with bitsetter

I have a bitsetter for my shapeoko XXL. When I start a project after seeing my zero it goes right to it and works great, but when it comes time for a tool change mid project (saving the gcode with multiple tool paths and a tool change so I don’t have to rezero) the router misses the bitsetter on the y axis. I don’t know why. It would be nice to not have to rezero.

1 Like

Maybe go in the Settings and check whether BitSetter coordinates are still correct? Or reset them (jogging to the position above it and selecting “use current location”)

3 Likes

Thanks. It works just fine everytime I start a project. It only has the issue tool change mid project.

I see. Any chance the gantry hits the front or back of the machine during the job before the first tool change for some reason?

2 Likes

Hmmm not that I have noticed. Also, if I load each cut as a separate gcode as soon as I stop the project and rezero it will go right to the bitsetter again.

This tells me that somehow the Y zero was impacted during the first job (and when you do the two-G-code files routine, you would not notice, since you re-zero in between ?)

Can you maybe run the two-separate-files again, as an air job if needs be, and before you re-zero for the second job, double-check that your X/Y zeroes still are where they are supposed to be ?

2 Likes

I can try that Tuesday. Thanks

1 Like

Just a shot in the dark…but when you set the coordinates for the bitsetter, did you enter into machine coordinates (absolute)? I would think that zeroing shouldn’t impact where the SO thinks the bitsetter is…I think those are supposed to be in absolute coordinates. The instructions has some secret easter-egg (how appropriate today!) click to get it into machine coordinates…did you do that?

1 Like

It always has it in the same place. How would I see if it is permanent?

Did you take all of these steps when setting it up…including clicking on the Position text (that’s the Easter Egg I mentioned):

  1. After homing completes, click Jog in the top menu bar.
  2. Click the Set Zero button. See Figure 16.
  3. On the Set Current Position screen, click the Clear All Offsets button. Then, click DONE. See Figure 17.
  4. Click the Position label. This will toggle the view to the machine coordinates. See Figure 18.
  5. Click Rapid Position, then click the SE button to move the
    spindle to the front-right of the machine. Once in position, click
1 Like

The only way we’ll know without guessing is if you provide a detailed, step-by-step procedure on how you actually use the BitSetter; actually. Not how you think its supposed to work; actually how you operated.

So many times this method has found that one step that the person misses.

2 Likes

It sounds strange that at the start of the job the BitSetter position is correct and then after running part of the job the BitSetter position is off. This is not possible unless you are losing position during the cut.

To set the BitSetter you go in to Jog and Set Zero and clear all offsets. Then jog the machine over to t he BitSetter and center the X and Y with the Z slightly above the BitSetter. Leave the router centered over the BitSetter and go to Settings Hit the Set Configuration button and on the first tab pick your machine and Z. Then go to the second tab and with the BitSetter checked use the “Use Current Position” and go back to the first tab and send configuration. You will get a dialog box with a fuel bar sending the config. Initialize and the machine should go to the BitSetter in the correct position. Write down the coordinates of the BitSetter.

Next time you BitSetter misses its position jog over to the BitSetter and check the coordinates. They should be pretty close to what you wrote down. If they are not very very close you are slipping on the axis that is off. Check the usual suspects like pulley set screws and V-wheels.

Alternatively set your machine config and the BitSetter position. Run an air job and then jog your machine back over to the BitSetter and the position should be very close, if not check the axis that is off. You may not jog exactly to the same spot as you set it for config but a few thousands/millimeters is ok but if you are by a bunch there is a problem.

2 Likes

I will give that a shot thanks. It’s hard to think that it’s slipping because it does such good cuts, but I will have to write the coordinates to see.

I’ll give it all a shot again next time I can.

Can you share a gcode file where this happens?

1 Like

All.nc (107.0 KB) This is one that had the issue.

Just now I initialized my machine when I connected to it. After initializing it stops in the front… I then used the jog to rapid position to the back and then manually had it move as far into the corner as I could get it to go. I then moved it to the front and reset my bitsetter position. Currently I am running an air carve that has two separate bits in the same gcode. This time it actually went to the right bitsetter location when I changed bits! I’ll have to run it again and see if it works.

Also, a lot of people have said that when you rapid set to the back corner it should say something like .5 for your zeros. Mine however only says 0.433 for the x and y which I actually closer than what it has said before today.