Tool change will not set zero on bit setter

I have a Shapeoko 3 XL. I have the short bitsetter, I believe the first one offered. I use Fusion 360 to generate G code. The code recognizes there is a tool change but will not go back to the bit setter to reset “Z” zero for the new tool. What am I doing wrong? This used to work just fine.

Is the BitSetter enabled in Carbide Motion?

There is a change coming to initialization coming but has not yet been implemented. So when you power on, connect and initialize does the machine go to the BitSetter? If so your BitSetter is enabled. If it does not and just sits at the home position you can run the configuration wizard to enable it.

If your BitSetter is enabled then it is something in the gcode causing your problem. Post your file ( or link to it in F360)and what post processor you are using in F360.

Yes, the bitsetter is enabled. I deleted the carbide motion application. Reinstalled it. Reconfigured the machine. The tool goes to the bitsetter as part of initialization. It’s just when running a program with multiple tools the program recognizes there is a tool change but won’t travel over to the bitsetter to reset “Z” zero.

Fusion 360 is using Carbide 3D (Grill) version 44104
Hot Plate Test.nc (3.9 KB)

What post-processor are you using? Post a G-code file? Make a test file from Carbide Create using “Carbide 3D Shapeoko” as the post-processor?

Sorry, Carbide 3D (Grbl)

There are no toolchange commands in the G-code

(2D Pocket1 2)
M0
(MANUAL TOOL CHANGE TO T3)
S5000 M3

The M0 should be M6T3 for the automated toolchange.

1 Like

In your tool library check the tool your are using in the toolpath and make sure the “Manual tool change” under the Post processor tab is not checked. This has happened to me in the past where it worked and for an unknow reason it started prompting me for a manual tool change. That’s when I noticed this box somehow was checked.

Edit: as @Tod1d the line that should trigger the automated toolchange will make use of the “M6” command and not the “M0”.

OK, thank you for the help. So is this a Fusion 360 issue?

AH HA! It IS a Fusion 360 issue. Thank you so much. In fact all my tools have this checked. I have to believe this will solve my problem. Thanks again.

Jim

2 Likes

That checkbox actually instructs the post processor to use the M0 command in the GCode file instead of the M6. The CNC’s controller understands that the M6 command means prompt for the tool number (in your example it’s T3) and then move and measure at the bitsetter to measure the offset before resuming the milling process.

(edit: I can only assume that will fix your problem, hopefully that’s all it is but it’s a good place to start)