Tool creation bug when computer is set to Dutch

I’ve stumbled across an interesting bug that arises when your computer’s region is set to the Netherlands (even if your system language is English). When I first tried Carbide Create today, creating new tools was incredibly buggy for me and was nearly impossible to do. I had to remove nearly all decimal points in the Edit Tool screen and only then it would let me save a new tool. I think I’ve figured out what’s causing the issue. In the Netherlands we use , for a decimal point and . for a thousand indicator. This appears to be messing with how Carbide Create stores tool data, with a decimal point in it, in the tool database CSV files. As soon as I switched my system region to United States and my system language from English (Netherlands) to English (United States), I could add new tools just fine without the buggy behavior. Would this be something that anyone has a solution for? as I’d really like to keep my system’s region in the Netherlands, as I use my computer for much more than just CNC work.

1 Like

This is a known issue.

It is being worked on (see the change log for the beta)

https://carbide3d.com/carbidecreate/beta/

612

  • (NEW) Allow comma as a decimal separator in most values.
2 Likes