Toolpath Issues

I am having a strange issue with Carbide create and a cribbage file that I am working with. I am trying to take 1/16 pocket out of all of the shapes in Blue. The one of the left that is not showing the toolpath will not take the toolpath no matter what I do. I have tried to close out and reopen, tried to assign the object its own toolpath, which showed the vectors were selected but then once I save the toolpath it states that the toolpath is empty.

Anyone have any ideas why this would be happening? I even copied the shape back in from the original file.

Is it a Layer issue? Might that section be on a different layer?

Please post the file or send it in to support@carbide3d.com and we’ll do our best to look into it w/ you

1 Like

Hi Will, I just sent over the file to support. Thank you for your help!

I only see the default layer unless I am not checking in the right place.

If you zoom way in on that vector, do you see any anomalies? when unselected, is it black or pink (magenta)?

When I unselected it is pink. I will try and zoom in and let you know. Thanks for the response!

The problem is this part of the geometry is unclosed (indicated by being magenta):

Select it:

and use the “Join Vectors” command to close it:

3 Likes

Since it never makes sense to pocket an unclosed vector, perhaps CC could issue a warning in this case?

CC ‘knows’ it’s unclosed, since it’s a different color.

There are probably other toolpaths that don’t make sense for unclosed vectors. However, I have had occasion to Contour unclosed vectors, so a blanket prohibition isn’t warranted.

1 Like

This fixed my problem! Thank you for your help!