Tooth path/z axis issue

Hey everyone, I just got my shapeoko pro XXL set up and have been trying to cut a super basic circle out. The problem is it seems like my z axis is trying to start at the very bottom of the tool path and not the top. I’ve gone over the setups several time and made adjustments to make sure all belts are tight. It looked as if using easel instead of carbide create solved the problem but after further review the cuts were still twice as deep as they should be. I was able to drill a single whole to the correct depth but upon trying to do just a line next it tried to go all the way through before I killed it. I really think this is an issue with the CNC itself and not the programming. Any ideas?

Try using Carbide Create and make sure you are selecting TOP of material. I assume you have a z-plus z axis. Make sure your config is correct and send it.

1 Like

I Did that. I was able to adjust some of the setting in the set up but it still cuts in double what I tell it to.

If you jog the Z axis manually in the air by 1inch, how much does it actually move as measured with a ruler?

1 Like

I have no idea. I’ll measure it and get back.

Can you post your NC code?

Not sure what NC code is. Just tried to jog the z an inch and it went 1.5 in.

It jogged and inch a a half instead of an inch

Did you configure the Z-axis for an HDZ when you have a Z-Plus?

1 Like

NC code is your program. You mentioned tool path and programming. It sounds like you may have a configuration issue though and should check / reload the correct settings for your particular machine and its Z axis.

3 Likes

The Shapeoko XXL Pro has two Z axis options.

Z-Plus Identifiable by the large lead screw in the center that goes through a rod with a hole in it. There is nothing at the bottom of the leadscrew.

HDZ for Shapeoko 4 Pro Notice the large black block at the bottom of the ball screw. The Z-Plus does not have the bottom block and you can see the bottom of the lead screw.

The HDZ has about twice as many steps as the Z-Plus and may explain why you are going double the distance if you choose the wrong configuration for the Z Axis.

4 Likes

This doesn’t have the rod with the pass through but it does have the lead screw. So it is a Z-plus correct?

Correct, Z-Plus (the HDZ is an option you’d have had to pay for and install separately).

1 Like

Awesome! Thanks guys. I’ll see if that fixes the problem.

Thank y’all! There seemed to be two issues with what I was doing. The first is I selected HDZ instead of Z-plus setting when setting up the machine. The second was that I selected G-code when saving my design with tool paths instead of using my specific machine. Correcting not of those haas fixed my problem. I was able to cut out my first circle :sweat_smile:. Thanks for the help. I’m sure I’ll be on here again.

4 Likes