Tried to download the latest software but .dmg wont open

I just tried downloading the latest versions of the software on my Mac and the .dmg doesn’t open so I can’t even install the latest software at this point. Is the server down?

I was able to download:

(but don’t have a Mac to test on)/

I was able to download and open the .dmg. I was also able to launch the motion app.


I was finally able to download the new version of Carbide motion but when I launched it and connect my Shapeoko XXL I got the following red error message: ERROR(1): GRBL ERROR: GRBL Version1.1 are not supported.

That’s strange as I’m running it on a Mac Sierra version 10.12.5

I have been using my XXL for over a year with minor problems but now I can’t do anything because if this

Can someone help please :wink:

Were you using CM3 before? It works with Grbl 0.9 which is what we were installing last year.

For CM4 or later you need Grbl 1.1 — you can update to that by contacting us at

Great thanks for the link William! So I downloaded the latest Grbl 1.1 and did the Z swtich hold while clicking Yes to update my xxl Firmware but when I clicked on the button: SEND CONFIG DATA for my XXL I don’t see the button to reset the homing switches anywhrere: TOGGLE SHAPEOKO HOMING

I tried a few time to send config data but still no Toggle button

There isn’t a button to toggle homing on or off anymore — homing is now mandatory — you should be good to go.

Thats again William, you were right I didn’t get that Error message again but my XXL is still acting the same way as before I upgraded to the latest soft and Firmware available…

This is was keep happening every time I run any kind of job I have been running on my machine in the last year I’ve own the XXL: Once I Load the file and Run a Job the % for job completion indicator jump to somewhere between 83% and 90% immediately without making the router move, then it goes up to the top left corner of the XXL and stops !?

I thought I needed to upgrade with the latest soft and Firmware to get it going since this started happening yesterday in the middle of a job but that it obviously not the case. I have no idea what is happening to my machine at this point, I’m stuck ;( do you have any idea what may be happening?

Please contact us at — let us know step by step what you’re doing, and provide any sample files you might have.

Were you able to do “Hello World”?

Yes Hello world work perfectly. Is the new version of Carbide fully supported for Mac OSx Sierra?

Carbide Motion 4 should be supported in the more recent versions of Mac OS X — I’ll try to loop in a developer.

do you have any of the old gcodes that you can try? Is it possible that its the job you are running now that isn’t processing properly?

Got it working now, thanks again for the help !!