Trouble Repeating Job - Shapeoko 5 Pro

Hey guys wondering if someone can help me with an unusual problem. I have a file that I am trying to repeat - 3 trays. So I run the first project. After I take the project off the board I place a new board down and then reset my x,y, and z on the machine. Everytime I start the project it goes the the correct spot where it starts the bowl bit at .10 however it buries the bit to at least a .25 of an inch and it is stuck. I am sure it is my error I just do not know how to fix it. I have even tried to initialize again and the same thing happens. Thank you in Advance.

So the first project completes ok? Then the 2nd one gets messed up?

Sounds like your collet may have loosened up between jobs and that would throw off your z. Make sure you use a couple wrenches to really tighten the bit in place.

I don’t think you would need to reset your x,y, and z each time either. If it’s the same job, you could make a jig to place the boards in the same spot for x and y. Your z may vary from board to board but it shoudn’t be much.

A couple of things to check.
How are you setting the X,Y, Z zeros?
If you are using a bitzero to set the corner, if you probe for x,y,z it needs to hangover the corner. If probing just z it sits on top.

If you are cutting them out of the same board and just moving the zero over (i.e. same thickness), I usually just translate to where I want the zero and set it (don’t probe).
If I am swapping boards, I set up stops to locate the reference corner and only probe z (if thickness is different)

How are you referencing bit length? Is it all one bit, or are you swapping during the run? What you use to measure x,y,x also needs to be measured by bitsetter to know the length.

And the one the has bit me a couple of times … are your bits tight in the collet? and is the board well secured? (I have had the bit pull up a board and make some ugliness :slight_smile: )


Thanks for the replies so far…

The collet is not the problem as everything is plenty tight.

Basically here is what I have done…

  1. Zero everything for first run (use paper method)

  2. Run the program
    A. First pass is 3/4 inch bowl bit
    B. Second pass is 90 degree bit
    C. Final pass is .25 inch bit

Then I take everything off the board…I then clamp the new board down

  1. I now zero everything again but run the same program…it buries the bowl bit

Surely I don’t have to shut down the entire CNC and redo everything do I?

What CM version are you on? Is it measuring the bits after each change and after you set Z zero?

I think it is the latest version…I am not plugged into my machine right now.

It is just weird how it buries the bowl bit.

If it isn’t measuring, or isn’t measure correctly that could happen. Is the lowest point on that bit what engages the Bitsetter?

yes I just use the bitsetter that comes with the Shapeoko 5 pro - I use it on all projects without a problem until I tried to simply repeat the project.

If I shut the machine down and reload the project I can run it with zero problem…I do not understand why I cant simply run the project 2,3,4 times in a row…

For instance I cut 3 trays out of the same piece of wood


Put a new piece of wood in the machine


reset the zeros to reflect the new piece of wood

Result - buried bowl bit to where the machine is stuck then I am forced to turn the machine off and a ruined piece of wood

Use a sharpie to draw a line around the shaft of the bits right up against the collet nut. Then after each cut look and see if it has moved. It seems unlikely the bit is slipping based on the way you describe it but good to check.

After the first one finishes and you go to rezero are you putting the 1/4 pin back in the collet or are
You resetting zero using whatever bit you have in the router?

If you swap back to the pin, do you tell CM that you are changing a tool? If not then it assumes the zero is based on the length of the tool that was in the collet unless you are on one of the newer versions which measures tool length after every Z zero operation. I think that started in 634 or something close.

If it isn’t rechecking the tool after you hit Z zero that could be the issue. The pin is shorter than your bit so it is try to go further down even though it measures the bowl bit. Remember that those measurements are not absolute, they are relative to the last tool measured.