Trouble saving GCode

Hi Carbide Community!!

I am new to the Carbide world and very happy to be a part of it.

I am having trouble saving my projects from Carbide create. When I click “Save GCode” it saves the file as a Text Edit Document. I’m not sure if I changed a setting at some point, somehow but does anyone have any advice on how I can change this back to normal??


Which version of Carbide Create do you have?

Is it adding the .nc file extension?

It’s harmless (and kind of convenient) to open the .nc files in a text editor — the only concern is that they have a file extension which will allow opening them in Carbide Motion — does that work?

I am using Carbide Build 514.

When I save the file it is not adding the .nc file extension. It is just saving the file however I name it and as a text edit document.

How do you suggest I save a GCode from CC to the folder on my desktop which I use to open projects in CM?

I am not VERY technologically literate so please keep that in mind when responding haha.

I need to figure this out as soon as possible and all your help is appreciated.

Thank you!

Please update to a more recent version — 514 had a bug on Mac OS X where it failed to add the file extension:

1 Like

As I was reading your post I think you might have mixed up saving your project and saving gcode. They are two separate things. Your Carbide Create project is a separate operation to enable you to reopen your project later in Carbide Create. Saving gcode is saving tool paths that Carbide Motion can use to cut out your project.

The Carbide Create files are saved in this format: project.c2d
The gcode files are created in this format:

If I misunderstood the problem sorry but Will Adams is right about the bug for Macs. The files for tool paths are still good you just have to edit it and add the .nc extension. All gcode files are text documents.

1 Like

CC does not add an extension automatically. There are other machines that use other extensions for G-Code even though it has the same coding to run it.
You have to add the extension needed for your machine. Using CM .NC is needed.
The Text files you already have just rename them with a .nc at the end and they should run fine.
To make it easier on yourself you may want to keep all G-Code files together maybe separating them into sub-directories by project, material, size or something more to remind you where it is.
I usually save my file so I can identify them better as well.
Like - Leaves 90V - 102 bit
Hope this helps.

Current versions of CC should add the .nc file extension automatically when exporting G-Code.

CM should support .nc and all other commonly used file extensions for G-Code (if there are any missing, let us know and we’ll see what can be done).

I have CC-526 and it does not add extension automatically?
I have to add manually.
I think I may know why.
There is a drop down box and it has several extensions listed on the line.
I may be able to click on the dropdown box and select one extension to have it come up with .nc from now on?

NOPE - “G-Code files (*.nc *txt *tap)” is how it reads. Even though there is a drop down box it only has the one option and will not save unless I type it in?

Please update to CC530:

Update to cc530 complete. Still the same saving G-Code all 3 listed and have to manually set extension.

Which OS version are you running?

Windows 10
What else would it be?

Okay, deleted the preferences for Carbide Create and launched it:

drew geometry:

created a toolpath:

exported G-Code:

to the desktop and choosing a post-processor:

and the file is


How do you delete the preferences before you launch cc?

To delete preferences:

  • launch Carbide Create
  • Help | About | Open Data Directory
  • delete the “Carbide Create” directory then revealed

All Good! Saves NC unless changed.
Thank you, I wasn’t quite following you, I understand now.


This topic was automatically closed after 30 days. New replies are no longer allowed.