Trouble telling Nomad where to cut

Did two tests, trying to learn to use my Nomad, and Meshcam. Decided to carve my kids’ initials into some 3/8" “craft board” that I got from Home Depot a while ago. No idea what kind of wood this is, it says it’s from New Zealand, if that matters.

The first test went pretty well, except the nomad tried to cut a border on two of the sides, and not on the other two, for reasons that I don’t understand.
Why would it do that? Very mysterious.

Looks pretty good:

Next test was to cut an “M” into a similar board. I took careful measurements, set my stock size and program zero etc, zeroed my machine to the point shown in this photo:

The machine proceeded to cut the air approx 1/4" above the wood. Very odd. Tried again, three times, remaking thing in Meshcam from scratch each time, same results. Clearly I’m doing things wrong!

The file I fed Meshcam in both cases is simply a white jpg with a black letter on it.

Anyone know why this is happening?


MrHume, is the Program Zero you set in MeshCAM at the corner of the bitmap and the top of the stock? It looks like you are pre-cutting the raw stock to be enough larger than the bitmap so the border is machined all around? If the stock is the same size as the final machining you’ll need to zero the cutter centerline on the actual corner of the stock. But I might be missing something in your setup.

Hi Randy,
thanks for the reply. I’m sorry but I’m such a beginner I’m not sure I understand your question exactly. The bitmap image is 300 dpi, 2.5 inches square. It’s a jpg that was exported from Photoshop.

Another odd thing is that the stock is 2.6 inches one way and 2.5 the other, and the Nomad tried to machine the other two edges - it just was cutting air.

I’m setting the program zero to the bottom left corner of the face of the stock. I realize now that the photo I posted doesn’t make it clear which corner the cutter is touching, but it is also the bottom left. Here’s some screenshots of my settings.

Here’s my “define stock” settings, note that I’m trying to remove .01 inches of wood at the top just to make it nice and level.

And here’s my program zero settings:

And here’s the jpg I’m using, in case it helps.

Any thoughts? I’ve been through a lot of forum posts and the like but I’m pretty stumped. Why would the cutter be trying to cut about a 1/4 inch above the surface of the stock?


OK, for the edge machining issue, you have already built the .05" offset into the stock definition. MeshCAM calculates the gcode relative to the stock, so the X0 is on the corner of the stock. So the Program Zero doesn’t need another X offset.

For the “air cutting” it looks like you’ve uncovered a bug in MeshCAM. I loaded the sample “fuzzy dots” bitmap image and scaled it to 2.5" square by .100" thick, black is negative. I sized the stock to the X and Y dimensions of the bitmap but made it .150" thick with a .010" margin above the geometry.


I then set the Program Zero dialog box to put the Program Zero at the top of the stock in the front left corner.

MeshCAM honors the X-Y position but does not honor the Z position, keeping it at the bottom of the geometry. This is a bitmap-input thing only, because for STL input there is no problem putting the Z zero even above or below the stock boundaries (I’ve done both).

With the bitmap input there also isn’t an option to shift the geometry so that Z0 is at the top of the geometry itself. I tried a workaround by reversing the bitmap image (swapping black for white) and told MeshCAM black is Z+ when I imported. That didn’t work. Program Zero is still stuck at the bottom of the geometry.

I’m pretty sure Rob monitors this forum closely, but it still might be worth an email to the support email to point out this thread. There might have been something I’ve overlooked myself, but it sure looks like a bug at this point.

The workaround for the time being would be to touch the tool to the top surface of the stock and set Z to +.11" instead of 0". With the Program Zero frozen at the bottom of the geometry, that is your .100" geometry thickness plus the .01" top margin. The part should machine OK then.

I’ll reply to my own reply. It wasn’t always so as regards bitmaps. In my lithophanes post at the MeshCAM forum I described

I imported it into MC and sized it for 4x3 inches and kept the .100"
depth range. I kept the material size the same X and Y dimensions as
the image, but set the thickness to .236" and set the top margin to
.100". This meant that the machining would be from Z-.100" thru

That was with an earlier release obviously…looks like Version 2 given the date.

Ok, I think I understand, thanks for all the help! One thing to note about the edge machining issue is that I am not intentionally setting the X offset to -0.05, it does that when I click the front left corner button. Even if I click “Set to Geometry Zero,” after I click the left corner it changes that value.

I think the fact that it only machined two edges may be caused by my incorrectly measuring the stock, but the fact that it bothers to machine the edges at all is what I don’t understand. I don’t think I’m telling it to do this. Does it automatically machine the edges on a bitmap image? Perhaps it’s trying to cut out my piece for me?

As for the workaround to the bug I seem to have stumbled upon, I think I understand your suggestion. You mean that when I zero the Nomad prior to cutting, I should set those values in the Carbide 3D interface, yeah? But what I don’t quite follow is how the +.11 will account for the thickness of the workpiece. I will try your method and report back the results. This is all very exciting, trying to learn how to think in the right way…

Thanks again for your incredibly thorough help! I really do appreciate it.

You’re welcome, MrHume. To avoid machining the edges select Machine Geometry Only and set a margin of 0. That will not take the cutter centerline outside the bitmap.

For the Z zero setting, it’s just a matter of setting the Nomad Z coordinate of the top of the stock (yes, that would be in the Carbide interface) to what MeshCAM says is the Z coordinate of the top of the stock. I.e. “go with the flow” :smile:

I’ll play more with the Set Program Zero command with bitmaps and see what I can see.

Just a quick update, I tried your work around and it succeeded! There’s a slight lip around the outer edge, but I think this is due to me setting the machineable area wrong.

This was a very valuable learning experience. Thanks again, Randy!