Unable to get past Initialization. Alarm 9

Hello all,

Finished setting up our new 5 Pro on Monday and can’t initialize the machine. When attempting initialization, the router/x axis carrier plate raises or lowers depending on the plate location and then down or up with a rattling sound. Software error code is
“GRBL Alarm 9. Homing Fail. Could not find limit switch within search distance.”

Checked all switches, wiring and walked back through the setup to verify everything was according to instructions but we’re unable to solve the issue.

Have reached out to support, sent pictures and a video of the initialization and hoping for a quick reply and remedy.

In the meantime, wondering if anyone else with the 5 Pro has experienced the same and solved for it?


There is a page on the alarm messages at:


which links to:


for troubleshooting — let us know what you find out at support@carbide3d.com and we’ll do our best to work through this with you as quickly as we can.

Hi Will,

We walked through the troubleshooting prior to posting and still are having the same issue. All switches are working and tested. No debris, All connectors and wiring looks good. I’ve read on a few other posts that removing the existing zip ties may unbind a particular wire, but given the switches all work, not sure thats the next purdent step. Still waiting on support to get back to us. Hoping they have some additional suggestions.

Picture of set up:

If the troubleshooting page doesn’t cover it, you probably need some replacement electronics — the support folks will work out what if need be and how to get it to you.

Problem solved.

After following all the trouble shooting and back and forth with support with the issue persisting, I decided to test all the individual wires for connectivity and found one of the black wire’s terminal was not pushed all the way into the switches pin connector.

Initialized and ready to go.


That is a hard one to find. Glad you were able to track it down.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.