Unable to re-flash controller

I recently got a jtech laser and lightburn. Got that side to work perfectly and made a few projects. I went to switch back to carbide motion and nothing would work. I dug around to see what changes i could make but haven’t found anything that worked. I decided i would just re-flash the controller with grbl 1.1 and start over but unfortunately carbides updated won’t work. After pressing the Z limit switch, it just sits at the updating screen, over 10 minutes when i taped the button down. I even attempted the prod button on the controller with no difference. Any thoughts? My machine seems to be useless as a CNC router at the moment…

Hi @keelejk,

First, do send an email to support@carbide3d.com, they’ll take care of your problem.
In the meantime, can you clarify what exactly is happening, does CM not connect to the machine anymore ?

Email sent. And ive made some progress while going through machine settings in lightburn. I don’t have experience with GRBL so i’m sure that’s where everything went wrong. Ive gotten my shapeoko to home but now right after, the Z axis shoots down and the machine drags forward. I have the bit length setter installed so that is supposed to be the next action. My settings in lightburn are set as they should but once i switch to carbide, nothing does. I’m hoping to just flash my board and start over but im unable to get carbides updater to work. It instructs me to hold the Z-axis limit switch and the program will update the board. I’ve held it for quite some time with no luck. It will just be stuck on the same “uploading firmware” page. Says it should only take 30 seconds to complete.

ok, if your machine connects and home, no need to reflash anything, it means GRBL is still alive and kicking.
The thing is, Lightburn uses slightly different GRBL parameter values than Carbide Motion, and this is probably what causes your problem.

To reset the GRBL parameters to their default values (for CNC/Carbide Motion use), you can just go in the Settings menu in CM, reselect your machine type & options, and click ‘send configuration’ (or something like that, I don’t have CM open right now). This should resend all GRBL params.

Hopefully that will restore your machine back to working condition, but then of course it won’t be correctly configured for using Lightburn anymore. What I do is, I have a set of macros in Lightburn to switch back and forth between CNC mode and Laser mode. See this post for example. It’s all taken from this video.

In CM v5 things were a bit different but i figured it out. The location of the bit setter was off but that was easy to reset. Thank you for your help! Now i just need to figure out how to safely use lightburn without messing all this up again.

1 Like

The Lightburn macro approach I mentioned is probably your best bet to have a foolproof way to switch between laser mode/Lightburn and CNC mode/CM, it takes 5 minutes to create those two macros.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.