Universal Gcode Sender issue

Hi, I am using UGS Oct 7, 2018 version (2.0) I have made a number of parts, probably 20x or so different ones, now this one part is stopping the program as seen in photo below with no error code, just total stoppage of the steppers (still energized just stopped). I did three runs, same thing but stopping in different places in my Fusion360 design, different operational steps. Any insight? Any alternatives that are Grbl 1.1 compatible and have served you well beside UGS and Carbide Motion?

The file was about 5000 lines of text, not too big, as I understand extreme smoothing orders thru CAM can cause data starving, well since this was slow running aluminum and simple runs I trust its not data starving
never know.

Also, this is the 32bit software. I could not get 64 bit to start at all, a Java warning, yet my machine is clearly 64bit.

Capture2, never know.


Happened to me on 64bit version a couple times, went to regular and haven’t had an issue. Just noticed you used the 32 bit.

Have you going back to an earlier version

I’ve tried every sender out there and have settled on CNCjs. It can be installed as a desktop application or controlled through a web interface. I run it on a $60 windows 10 tablet with issues.

Thanks fellows.
So 64 bit said my Java was expired, I checked both Java and JRE, they were good. Then 32 works very well, until tonight, I think, 90% think, I have it figured out.

My Win 10 laptop had USB control and USB hub set to allow the computer to power manage them. After an unspecified amount of time, it stops the USB. This is time from last touching the computer, I assume… So The stop point was different each time. Prior cuts were under 8 minutes or I was on the computer doing stuff, this was different. The facts align pretty nicely, including that I just did some milling in the air to test, and it’s good!

I will look at CNC js just for kicks. My only issues with Carbide Motion are the frequent homing (once per operation) and the jog controls are not set up for fast setup for me. I would otherwise consider the ‘provided’ software to be as good as any. I just wanted to get speed up from day one, so found UGS.


1 Like

I added a couple troubleshooting steps you can try to the documentation.

  1. Check the controller settings, and make sure “Arc Expander” is not enabled. This can take a small program and turn it into a very large one by converting arcs into many small movements.

  2. Increase the memory allocated to UGS by navigating the the installation directory (See paths above). There is a folder named etc containing ugsplatform.conf, open this file with a simple text editor and modify the value of Xms to something like -J-Xms256m, or larger. Additional details can be found here.


Thanks Winder. I tried your two tips, no luck, the machine still cuts out near the end of a run 2/3 of the time. I guess I had not figured it out with the USB power settings.

I tried CNCjs, same deal cuts out after about 8 minutes. May try a linux laptop instead.

Neilferarri: So on CNCjs, what are the FSR controls on the left. I know F is feedrate adjust, but the other two?


Those are the grbl real-time overrides:
F is feedrate
S is Spindle speed
R is Rapid move rate

Can you share the gcode?

1002.nc (46.8 KB)

Gcode attached, So many of the stops are happening when the first contour cut is 75% down it’s many circles, at the specific point where it would rise and plunge again. Afterward the axis indicators all go to zero and the program locks up, so I cannot access any data on CNCjs. I am having more problems actually milling aluminum than ‘cutting in the air’ to test it. I have tried additional interference by overloading the 120v plug with a heat gun, oscillating makita speed a little, to see if I can provoke the failure with something identifiable, not happening.

Receive buffer goes from 17 to 51 in that range, occasionally flashes orange to a low number when doing both X and Y turns (maybe you have experience interpreting that)

Gcode checks fine. Most likely not an issue with the sender.
Probably an EMI issue. I’d try:

  1. Running the router ad the machine power on separate circuits (and opposite directions…keep that noisy AC away from your controller)
  2. A different USB cable. A decent one with ferrite choke.
  3. A different PC

Do you have any issues with air cuts without the router on? If not, I’d say 99.5% it’s an interference issue.

have you tried $c. This will run through the program without any stepper movement, also much faster. Its very helpful for detecting errors. If that checks out im with @neilferreri, hardware interference


Have you tried it with the visualizer off?

I added ground to Y axis gantry, then ground to X axis plate, (the springs conduct to the Z axis plate), and then scratched off paint for makita-holder block bolt, to make conductive path to it… Also running the laptop plugged in for ground. It does not stop. So interference. I have made several cuts, think it may be solved now. Thanks.

(I am having another issue I will detail in another post here, 1/2 related.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.