Upgrade to grbl 1.1 / CM 4 Limit Switch issues

Howdy all, long time no see.

I decided to upgrade and I’m running into some strange issues.

The homing sequence hangs and let’s me know it “couldn’t find limit switch”

However when I manually press each limit switch (x, y, z) it reads in the error log above.

I’ve tried all common resets to fix and uploaded the correct info from CM4 to my Nomad Pro.

Any help would be appreciated, I hope you’re all well.

Much love.


Hey Hank - I have been holding off on moving to GRBL 1.1/CM4 as well just in case things go wrong and stop my ongoing work so have no brilliant insights unfortunately. Given the dearth of responses probably time for emailing support@carbide3d.com. Make sure to share how it turns out!



Does it drive the correct direction toward the limit switches? When I did the upgrade, I needed to reset the settings. (Is it one of the steps?)

I have the same issue. Tried to go back to CM3 but the machine makes a horrible grinding noise and will not home at all.

Anyone make any progress?

To revert to 0.9 see: GRBL 1.1 and Carbide Motion 4 — you can use those tools to update to 1.1 as well — just grab the 1.1 hex file from the updater page.

i tried to revert to 0.9 and cm3 like this post already. issue persists.

Please check in at support@carbide3d.com — let us know your board revision and we’ll do our best to help you sort this out.

I just upgraded the firmware and Carbide Motion, had the same thing happen. In fact the red EMERGENCY button fell off because I had to whack it so the machine wouldn’t tear itself apart (replacement??), but I did stumble into the solution for fixing the smashing into the right side, as if the limit switch wasn’t working.

Power down the Nomad. Quit Carbide Motion. Power up the Nomad. Launch Carbide Motion. Do the Connect in Carbide Motion. DO NOT Jog or try to Home. Instead go to SETTINGS in Carbide Motion.

I’m not sure exactly what I did but I set a few things to whatever made sense, and completed that process.

I think that doing the firmware update erased machine characteristics in the Nomad’s controller, and by going through the Settings process they got put back. As soon as I did that, Homing worked just fine. Machine now works.

Now, where do I get a replacement Emergency button??? (I have read that only the original Nomads have/had them.)

I think there are notes somewhere about the fact that yes, the GRBL upgrade wipes out all the settings, and the upgrade notes are VERY clear to not do ANYTHING except update the settings when it gets power cycled.


Just so someone can find it… If you upgrade to 1.1, then decide to go back, your settings are still wiped out, and you still need to follow the “settings” directions to set them back up. Just going back to .9 won’t magically fix things. The settings are wiped out going to 1.1, and therefore, aren’t there for .9 either.


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.