USB device not Recognized

Hello fellow Shapeoko users,

Just when I think I’ve got all the bugs worked out with my machine I’m now getting and error when I plug in the USB cable to the computer that runs my Carbide Motion. The error I get is:
“USB Device Not Recognized. The last USB device you connected to this computer has malfunctioned and windows doesn’t recognize it.”

I’m using Windows 11 on a leveno laptop, and using the current version of CM. Before I loose what little hair I have remaining, can anyone suggest a solution for this problem?


First, make sure that you are powering up the machine w/ the power supply so that the motors lock &c. and that the USB cable is a good one and securely connected at both ends, and any adapter is good quality.

If that doesn’t get you connected, contact us at and we’ll work through this with you.

How long is your USB cable?
Good quality?

1 Like

@WillAdams that’s what I have been doing, without any success,

@Mseguin & @WillAdams, it’s was a 6ft cable that I got when I bought it from the previous owner. I just bought a new cable last night, but haven’t had a chance to try it yet. I’m going to try it tonight or this weekend.


Ok, so I tried a brand new 6ft good quality cable, and I am still getting the “USB device not recognized
The last USB device you connected to
this computer malfunctioned, and
Windows does not recognize it”

What can I do to fix this problem?

What e-mail did you use? (let me know in a PM) I’m not seeing a ticket since the one in 2 May when we advised that you needed proximity switches.

I haven’t submitted one yet. I wanted to try a new cable first. I’ll submit the ticket asap.

Hello, not sure if you got this fixed or if its even the same problem I had. Did you try a different computer? This happen to me when I updated my computer from the old version of windows to windows 11. Not sure if that is what you did? It worked on the first day then stopped. Thought it was my machine. For months I couldnt figure it out. Going back and forth with tech support, updating the usb ports, new cables nothing worked. I bought a new computer and it finally worked. So then tried reverting my old computer back to the previous windows and it worked fine. The funny part, My new computer is windows 11. So something on my old computer when it updated doesnt like my shapeoko anymore.There is probably a fix for it, but all the fixes I found online did not I just leave it on the old version.

1 Like

This topic was automatically closed after 30 days. New replies are no longer allowed.