Using Vectric VCarve Desktop and CM

I installed the Post-Processor provided by Neil Ferreri. When trying to save the toolpath as one file I get the following error…

Error: Toolpaths…
‘Path 1’
‘Path 2’

both use tool number 1 but the geometry of the tools are different.

Curious if anyone has some insight into this issue. @neilferreri
Im sure it is something I am doing incorrectly because many of the threads show things are working for others. I do have a bit setter.

Its also worth mentioning that I manually edited every tool number for each bit within the bit settings. Each bit is numbered 1-10.

Do you have two different tools designated #1?
Can you get a screenshot of your toolpath list?

1 Like

Attached. Sorry for the image, havent used Windows in years.

The image shows that my clearing bit is Tool #1 and my V bit is Tool #7.

How about the screen where you actually export toolpaths, where it shows the list of toolpaths you’re exporting?

Edit: I see you have included that.

What version are you using?

I did notice the tooth paths to be saved all have a [1] next to them. I recalculated the tool paths but they remain [1]. I think this is my issue. Running 10.512 VCarve Desktop.

So I got it to work. I had to change the tool number by selecting the edit button next to each drill bit vs changing it using the select option.

That’s the problem. I’m not sure why. Can you try to edit those tools again and see if it takes?

EDIT: I see you did that! Happy carving!

1 Like

I think I had a similar issue the first couple of times I tried to export a multi-tool file.

Since then I’ve gone back into the tool database and started to create a custom database for the tools I have in stock using either the manufacturer’s PN or last 3-4 digits of the SKU on the package as my tool number. So far so good.

I use the pattern masks to name the tools so it’s easier to see what’s what. This can be set globally with the little edit button next to the bold version of the name. Using this pattern:

[{Tool Number}] {Machine Name} : {Material Name} : {Num Flutes}F - {Diameter|F}{Units Short}

You get a list that looks like this:

and if you switch materials and machines:

This custom format carries over to the toolpaths:

image

For numbering, I use a homebrew formula. Since they can really only be 3 digits long in GCode, I use the first digit to represent the number of flutes and then the second two digits is the diameter in mm. So a 230 is a two-flute 3mm endmill. For balls I use an 8 in the first digit since it looks like a B, and for V mills I use a 5 (since it’s V in roman numerals) and then the angle as the second pair. So a 560 is a 60 degree VBit.

3mm or 30mm? :smiley:

I was thinking that Neil told me that the limit was a binary 8 bits which would make the limiting number 255 (or 256.) I’m completely unsure of that, though.

230 is 3mm. So 231 is 3.175mm (1/8”) and 260 is 6mm. I do have 205’s and even 203’s which are 0.5mm and 0.3mmm.

It could be a 2-byte number and not a 3 digit number. Main issue was you can’t enter 4 digits in things like camotics.

2 Likes