Vcarve toolpath incomplete

I’m sure I’m overlooking something fairly obvious, but I have a fairly simple star shape I’m trying to do an advanced Vcarve on, and it’s not completing to the exterior of the vector. I’ve tried doing both Vcarve and Advanced Vcarve, but two or more points of this star do not get a toolpath generated.

I’m sure it’s just me, but I’ve never come across any behavior like this before, which is why it’s so perplexing. I’ve attached the c2d file as well.

WestonSign.c2d (252 KB)
Looks like I forgot the file. Here it is.

This has been seen before. Very sharp points can confuse the V-carve engine. It is a bit tedious but easy to work around. go into node editing and insert a node very close to the point that are giving you trouble. then drag that point to be almost on top of the original. You will end up with the shape you desire. The distortion at the tip need only be a rounding errors different from the original.

Highly zoomed
image

After editing

Tool path

6 Likes

Another option to consider is swapping out that 60º bit for a 30º. Reducing the max depth of cut and step over seems to yield good results.

WestonSign.c2d (252 KB)

Excellent! I added the vector and it worked just as you described.

Is this an issue exclusively with Ccreate, or do other CAM tools suffer similar issues?

I would use a 30 degree, but I don’t have one that fine. The only VBits I have on hand are a 90 and 60. I do intend to pick up a 30 for fine work.

I have a 15 degree vee bit that I use for very fine lines. If I use the 60 the preview looks so light you can almost not see it. With the 15 you can cut very fine line. As @Ed.E suggested limit the depth because a 15 degree can cut quite deep. The 15 degree is good for small text also.

So that’s actually a question that I had, if you’re doing a Vcarve but limit the depth, does it effectively become an ‘Advanced Vcarve’ path?

No, they end up being very different. A VCarve tries to trace the ‘middle’ of the vector, an advanced VCarve follows the perimeter.

From left to right (All on the same size rectangle):

  • VCarve, full depth
  • VCarve, .1"
  • Advanced VCarve, no clearing bit, .1"
  • Advanced VCarve
    Screenshot 2023-01-17 013012

Most of the time you wouldn’t limit the depth of a VCarve, it just ends up looking weird.

3 Likes

This seems to be a quirk in Carbide Create. I exported your SVG and brought it into Vectric VCarve corrected the scaling and was able to get the desired profile without additional effort. That said the path planning is very different where Vectric appears to always be in an advanced Vcarve mode giving you the option to set a flat depth and clearing tool(s). It is also not inexpensive software with quirks of its own. I can’t speak to other packages.

I really wish I could justify software like Vcarve, it seems to be a community favorite, but the price is just so astronomical. Plus it doesn’t have a MacOS version, which if it did, would make it easier to justify.

What @LWSIV said but one exception. If you have very fine lines to start with and a 15 degree vee limiting the depth can work. The reason is a vcarve tries to plunge down the center of the line until it touches both sides of a line. So with a very small vee bit it can make quite a deep valley to touch both sides of a wider line. So if you have very thin lines like small text limiting the depth will work. If you have wide lines with a 15 degree bit then it will make very deep cuts. So as @LWSIV said it can come out weird if you limit the depth except on very thin lines/characters. So the wider the line the 60 or 90 degree vee might work better. You can do a simulation and the same thing with a 60 might look very pale and hardly able to see. With the 15 degree the simulation looks very good. So you have to experiment to get the balance between the width of the line, depth and the angle of the vee bit. Do not experiment on your good material. Try out the experiments on scrap.