Vector from jpeg...dxf files

I was wondering why I am having so much trouble creating a vector that works so my machine could cut out shapes. I have a jpeg of different shapes that are to scale. I created a DXF vector file using inkscape. Carbide Create and Meshcam both crash when I try and open them. I tried creating a vector from Scan2cad and the something happened. In Carbide Create it seems the only thing I could do is open the image as a background image and trace over it, but that is extremely time consuming and then I have to mess with the scale to get it to fit. DXF won’t even open in Meshcam for some reason even thought there is an option to open DXF files. This is very frustrating since the whole reason I bought this CNC was to cut out these shapes. Thanks!

If you have the file in Inkscape, save out as an SVG — that seems more straight-forward. Note that best results are had when you:

  • view as outline mode before exporting — what you see is what Carbide Create will import
  • set up as a composite path w/ correct winding (outermost path counter-clockwise, next clockwise and alternating as need be)
  • no overlapping or intersecting paths

If you have trouble with a file, please post it here, or send it in to and we’ll do our best to help.

Thank you for getting back to me. I saved the file as an SVG in Inkscape, but when I import into Carbide Create I cannot see anything. I magnified all the way out…
I have attached a copy of the SVG file as well as the original JPEG.

The SVG seems to be empty, just 474 bytes. Looking at it in a text editor all I see is:

<?xml version="1.0" encoding="UTF-8" standalone="no"?>
<svg xmlns:dc="" xmlns:cc="" xmlns:rdf="" xmlns:svg="" xmlns="" xmlns:xlink="" version="1.1" id="svg2" viewBox="0 0 744.09448819 1052.3622047" height="297mm" width="210mm">
  <defs id="defs4"/>

  <g id="layer1">


View as outline in Inkscape before saving — what you see then are the paths more or less as they will be seen by Carbide Create when it imports.

The JPEG is either incomplete or shows open paths — Carbide Create does not cope well with open paths (it only allows a follow path option, and then will close them, so they’re not useful and might as well be closed, since that’s the effect one gets in the current version).

Okay, so I close the paths by connecting all the lines, then should work?

If all the lines are vector paths which show in outline mode when one is in Inkscape and if they have proper winding and don’t intersect or overlap.

The problem is, right now you have a pixel image — you need a vector.

I think I’m on my way to getting it now. I changed the image to a vector in outline mode, and was able to get it to show up in Carbide Create. Thank you very much! that was extremely helpful.