Vectric Desktop V11 - how to add a post processor

I just upgraded to V11. I haven’t figured out how to add the shapeoko tool change post processor. Any ideas?

Did the process change? I’m still on V10 where it worked like this:
To add a custom PP, go to File => Open Application Data Folder, it will bring you to the right directory on disk, just create a subdirectory called “My_PostP” there, and place the custom PP file you want to use in there. Close VCarve, restart it, and in the toolpath generation PP selection dropdown list you should now only see the PP (or PPs) you have in your My_PostP folder

Yes, it changed. They now have a machine manager. Go into save tool change. Do an add post processor. Put a name in for your machine. In the lower section of the window: a file ssociated post processors, do the ‘+’ and pick shapeoko (inch) from the list. Then do it again, but this time in the widow with lists, in the lower left corner hit the file icon and make your way over to where your new pp is, and add it as the default.

1 Like

I thought I read you could still just copy them into the post processor folder, the same way it’s been. (In addition to the other, new way)


In 10.5 I wanted access to both (inch) and the tool change PP so I loaded the tool change version into the PostP folder and had access to both. In 11.0, the PostP folder did not have any Shapeoko files. Maybe if you put it into the MyPostP folder it would work. After I got it working I went back and looked in the PostP folder and still didn’t see a Shapeoko file

Having just run the upgrade to 11.003 I migrated PostP from 10.5 and they are in my PostP folder, and the settings to show this folder only is still there. Within the Machine setup, I was able to select these (can choose multiple entries) against my machine and it works correctly. You still have ‘open application folder’ in the File menu, so stuffing the wanted PostP files into MyPostP is still an option.

I am having the same issue. Found my tool change post processor and loaded it in but still having issues.

What kind of issues?

Cribbage board 5 tool changes but the carve will just stop after first bit done. I am using your file on the post processor but the new version V11 does not seem to recognize the code as a group of carves. I am guessing it is something not recognizing I have multiple bits and carves but I don’t have the knowledge to figure it out.

A picture of my file. Only the 401 bit will cut.

Why is saving toolpaths only saving the highlighted tool?

Because you are using “Selected toolpath” when you save.

You need to use “Visible toolpaths to one file”.



1 Like

OMG, what a rookie mistake! Well, thank you!

1 Like

From what he posted, I don’t think I understand your response, Neil. Perhaps I didn’t read far enough back, or something?

Visible tool paths to one file fixed it.

1 Like

I was saying this is the solution, referring to your comment which I quoted.

:smiley: You might want to edit your comment then, and move the big red arrow one click up, or someone might get confused. :smiley:

I mean…what are you talking about?

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.