Vectric File wont load

Has anyone had a problem loading a Vectric file into the carbide motion program?

I can’t get a file to load into the program, I have scrapped the file and done it again but still have the same results. Other files still load OK it is only the one I am having the problem with.

I wrote up a bit of a tutorial at:

If you’ll let us know where you’re stuck we’ll do our best to assist.

Carbide Motion reads GCODE files. If you are trying to load a Vectric project file (*.CRV), CM will not load that.

You need to create tool paths in whatever Vectric software you have and save out the resulting GCODE to feed to CM.


To avoid any possible confusion I will say that .crv is Vectric’s format for the design file (similar to C3D’s .c2d file saved by Carbide Create), while the .nc format is for the Gcode file generated either from CC or Vectric products, and that’s what CM Can run. Don’t go renaming a .crv file to .nc extension, it will not work (it may just be me who read it that way, but just in case)


As Julian says, do not rename a CRV file to a NC file. It’s like renaming a DOCX to a PDF.

1 Like

Sorry guys, I meant Carbide Motion and not Create. I understand the difference between the codes, for some reason the post processer would not load when inch Was selected but actually worked when I selected mm. This confused me as I work in inches and normally works fine. So by selecting Shapeoko mm post processer solved my problems. Thanks for the replies and coming back to help me.


This topic was automatically closed after 30 days. New replies are no longer allowed.