Vee Bit Issue - VCarve toolpath starts too high

Hello all! I’ve searched the forum but I cannot seem to find anything that quite matches my issue. My dad and I recently purchased a Pro XXL and have been trying small, simple projects to get a feel for the machine. Basic shapes using the end mills and ball mills have been going great, but we’re running into issues with the vee bits. When cutting a vcarve toolpath the bit seems to always start too high, and doesn’t actually cut deep enough into the wood (compared to the simulation in Carbide Create). Here are some photos of the most recent project with the issue.

As I said, the endmills work just fine and the issue only appears to happen after switching to the vee bit. Here’s the process we’ve used (from the time the Pro XXL is turned on it is not turned off or disconnected):

  • Connect the computer, turn on the machine and initialize it
  • Use the change tool function to load the BitZero probe. The machine then checks the height with the BitSetter.
  • Run BitZero probing routine, lower left corner setting. We make sure that the BitZero is set on the wood so the corner of the material is aligned inside the recess properly. The probe sucessfully zeros the x axis and y axis within the hole then zeros the z axis by touching the top of the BitZero
  • Change bit routine to load the end mill. The machine then checks the height with BitSetter.
  • Load the job and start. We click continue on the tool change since the end mill is already loaded. Once again the bit height is checked with BitSetter.
  • The job starts. We watch with glee as the end mill does its thing and makes beautiful cuts!
  • The machine prompts us for a tool change. We load the vee bit and the height is checked with BitSetter (the vee bit is shorter than the end mill)
  • The VCarve toolpath starts. There are some moves/passes with the vee bit that should cut the shallower details in the wood, but instead they float over the surface. Likewise the deeper cuts don’t go deep enough.
  • The job finishes. We look at it scratching out heads because the VCarve looks nothing like the simulation from Create.

Anyone see this happen before? Any insight or advice would be appreciated!

I’ve also attached the actual create file:
Tree Sign - James.c2d (206.3 KB)

Your stock thickness is 0.75" and you are setting your zero at the top of the stock:

When you load a V endmill, and set zero at the top of the stock with the V endmill are you then able to move the V endmill down 0.26" so that it is 0.24" above the surface of the MDF w/o bottoming out?

Wow, you guys are fast with responses!

Sorry, I don’t follow. The only time I zero to the top of the stock is when I use BitZero and the accompanying 1/8" or 1/4" probe. BitSetter handles the end mills and vee mills from there.

Please try setting zero w/ the 1/8" probing pin inserted to a depth to mimic the stickout of the V endmill you are using.

Then see if you can move down to as deeply as the V endmill will cut w/o bottoming out the Z-axis.

I will certainly give that a try when I visit my dad’s house (where the CNC is located) this weekend! Though, because the vee bit sucessfully depresses the button on the BitSetter (bed level) doesn’t that rule out Z-axis issues?

I can also take a video of the whole process this weekend as I imagine that might be easier to spot where I might be going wrong vs deciphering my writeup of steps I’ve taken.

To me it sounds like a Z axis zero issue. Just because the tool successfully probes on the BitSetter, does not rule out Z axis issues. Could be an issue of stock height incorrectly set in your CAM software. If you buy stock material of a specified size, always measure (with a micrometer) to verify the correct dimensions. I would create a job with the zero set on the top of the stock and see what happens to aid with troubleshooting.


Might be a long shot but is Fusion 360 used to create the gcode? If so, check to make sure your ‘Bottom Height’ isn’t set at the same level as your "Top Height’. That can start the tool higher than intended (safety feature of Fusion I think).

1 Like

one thing to make sure is that the collet is tight enough… if the vbit “pushes in” then it’s now shorter…
(if the shank feels a bit greasy, a bit of degreaser might do wonders… also make sure you don’t have a 6mm shaft V bit in a 1/4" collet. They’re close. but not THAT close)

not super common to be fair, but I’ve had it happen once or twice.


Thank you all for your suggestions, however I was not able to re-create the issue when I was working with the machine today. Or rather, I didn’t re-create the issue. I read on another thread that someone was able to fix their issues by loading the job before doing the zero-ing routine. So when I ran my projects I loaded the gcode and then ran the zero routine with BitZero. This time around everything worked well. Is there actually a difference between running zeros before or after loading the job?

The only other thing I can think of is I did encounter a quirk with the BitSetter. The button is capped with a neodymium magnet. When the endmill raised after depressing the BitSetter button the first time it lifted the magnet which got caught on the top of the rim in which it sits, effectively changing the surface contact height between presses. I did away with the magnet all together, but I wonder if this quirk contributed to the original issue.

Since I was using the BitZero the slight variances in material thickness should not have contributed to the issue. All of my software configurations were set to use the top of the material for zero-ing. You may be right that it was another z-axis zero issue, however, as I discovered the magnet on top of the BitSetter button has a tendency to be picked up with the endmill and not land back on the button correctly. This would essentially change the BitZero button height between endmill changes if it went unnoticed.

There shouldn’t be. More likely a coincidence.

That may well have been the issue, if the Z offset you noticed is roughly the same of the depth of the magnet rim.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.