VFD not responding

I purchased the VFD from Carbide 3d with my 5 pro. The spindle has been working fine till yesterday. I even went into MDI and tried M3S10000 and it will not respond. Did all the unplugging and resetting and still nothing. Ha anyone else had these issues? I did put in a trouble ticket in the support section.

1 Like

I’m on my third VFD for my Shapeoko 5 Pro. I’ve had the situation that you’re describing with one of my controllers and I’ve also had one situation where you couldn’t command any RPM value over a certain speed via the MDI. Unfortunately it looks like the quality control of these VFD controllers is very poor. It’s too bad that Carbide 3D’s support team is saddled with dealing with all of this because they don’t make these controllers but I’m sure they’re very aware of the problem you’re having. If you search this forum, you’ll see several threads dealing with VFD issues.

I think it’s also the case of people with no problems don’t get on the internet to report they have no problems. So an issue looks way worse than it is. I have their VFD spindle on two machines and haven’t had a single issue. One has been on our S4Pro at work for a year and a half. The other on my S5Pro since they were released.


Having been involved with process improvement in manufacturing and back office environments, I can tell you the goal should be zero bad products shipping. The number of issues I have seen leads me to believe the first reply is not wrong: there are absolutely QC issues.

I’m sure those that work are amazing. Since I am also having the same issue, though I just discovered it because I couldn’t even get to that step for a couple of days since I still can’t get my machine to initialize successfully for the first time, the positive experiences of others don’t give me the warm fuzzies.

1 Like

This is very true. All the posts on the forum are about the problems users are having.
I follow the issues regarding the VFD spindle with great interest for when I decide I need/want one. The lack of positive experiences gives a very skewed view of how big reported issues are.

But without statistics to show how many are out there in the wild vs. number of reported issues, one has to make a conscious effort to remember that the units aren’t all problematic.


Normally I would agree with you if people would report having only one bad VFD box. I have had two bad VFD boxes and ksymons reported in this thread of having two bad VFD boxes as well. I have seen numerous others report not having only one VFD box failure but multiple. Statistically speaking this tells me that the percentage of QC problems is most likely quite high.

I appreciate all the feedback but what I need is a fix. I have a project due for a retirement next week and my machine is down…

Let us know about the urgent aspect of this at support@carbide3d.com and we’ll see what can be worked out.

I sent you a PM about a potential way to get you up and running today. I know of a few other methods as well.

I already put in a ticket in your support section. I just need someone to call me


Original VFD Controller 1.1

Replacement I received today…

Neither board is providing continuity between ground (black wire of 6 pin harness) and the chassis, which others have suggested should be the case for a working VFD (eg Gibs). Waiting to receive replacement SO5 board as well, since it was not outputting any voltage on the black/white pair (regardless of M3 commands).

I’ll update if the new SO5 board resolves matters. Perhaps they changed the grounding plan for the VFD I have (e.g. isolating from common mains ground).

1 Like

Wow, thanks for the pics. My new board should be here today. Fingers crossed that this is the problem.

FWIW - Spoke to C3D folks about the board rework. It is known to them and intentional, presumably to overcome a design or post-production issue.