VFD/Spindle confusion

Ok, in need of some help here. I’m working on getting the 800w spindle hooked up. I had it tested when I first got it just with simple wiring and everything spun up. Move on to tonight.
I have the 2.4 version of the motion board, and have pin set into both PWN locations.
I wired up the pwm wire, and ground wire. PWM goes to VI, and ground goes into the top ACM. I also jumped the DCM and FOR on the top rail. I have the VFD set to the following:

001 = 1
002 = 1
004 = 400
005 = 400
008 = 110
011 = 100
014 = 2
015 = 2
070 = 1
073 = 100
141 = 110
142 = 3.7
143 = 2

I have also set #30 to 24000, $31 to 0, and $32 to 0.

It should be noted I have a Jtech laser running from the shapeoko with no issues.

Now, here is what is going on. When I provide power to the VFD, the motor spins up no issue, and I have general control with the knob. I hit the stop button, it shuts off. IT WILL NOT TURN ON AFTER THIS. I turn the knob, press START, nothing. I turn knob back, press start, turn knob, nothing. I have zero control through the machine, I use bCNC as my sender and editor. I can move the machine no problem, but I have zero spindle control. As far as I can tell, I am NOT getting any voltage from the PWM line, but…since the laser works, I have to assume it’s functioning.

So basically, if I stop the spindle after I initially plug in the VFD…I can’t use it anymore if I want to run it from the CNC commands. If I set 001 back to front panel controls…I can start and stop, but that defeats the purpose of a spindle so…

Any ideas!?

Hi @MaddTraxxRC,

  • I’m a bit confused why START/knob have any effect if you set PD001 and PD002 to 1 (which should tell the VFD to operate based on the PWM input, not the Start/Knob buttons)
  • Before hitting STOP, is there any scenario where you have spindle control from the Shapeoko ? (e.g. using M3/M5 GRBL commands from bCNC)
  • On my VFD (Huanyang) the behavior of the VFD after STOP is pushed is controlled by the PD024 setting, and the documentation states this:

"When the control mode is set for external terminals or communication control, STOP key on the
panel can be chosen to be valid or invalid. When choosing it as valid, STOP key can stop the
inverter in running. When it needs to restart, the former running signal must be released before
restarting the inverter ."

So for the sake of testing you could try setting PD024 to 0 and see if then you can control the spindle through M3/M5. To confirm whether the problem is related to that setting, with PD024 set to 1 you could also disconnect/reconnect the PWM signal after hitting STOP, see if you can restart then.

Finally, to double-check that there is nothing wrong with your PWM wiring, with your VFD turned off you can type M3S24000 from bCNC and check with a multimeter that you see ~5V between VI and ACM

EDIT: there is also this thread about a situation similar as yours, but it turned out to be a wiring issue. You can still have a look for inspiration.

1 Like

Ok, so first thing I did was check voltage. It’s strange. I can turn on the spindle control in bCNC, and I get voltage, but it’s strange. I can move the slider from 0-12000rpm, volage goes from 0-2.1v. After 12000, it starts dropping on the same curve back to zero when I hit 24000rpm.
Both PWM locations give me that result. (This also makes me wonder if my laser is ever getting full power)

I check continuity of the signal wire from the board to the VFD, no issues there.

With the signal wires plugged in, vfd on, I send a M3S12000 (should read 2.1v), and nothing happens, but I do have the voltage across ACM and VI. Changing 024 had no effect.

Hi Dan,

Strange indeed. I never used bCNC, so I would recommend to only stick to M3/M5 G-code commands while investigating this, instead of that slider, just in case (to remove one parameter from the equation)

If you type M3S24000, do you get 5V at controller output / VI input ?

If $30/$31 are properly set to 24000 and 0, there is no good reason to not have 5V on PWM.
If you don’t see that, unplug the PWM on the VFD side and retest. If you still don’t get 5V…well we’ll see. If you do after unplugging, that would mean a weird electrical interaction with theVFD.

Only once you have made sure that PWM output is fine and under control, proceed to investigate why the VFD would not react as expected. A quick and easy step would be to reset the VFD to factory settings (via PD013) and reapply the PDxxx values you mentioned. Sure, it should not change anything, but it will rule out the possibility that while investigating at some point you changed something ELSE and do not remember doing it :slight_smile:

if the spindle does not start when sending a non-zero voltage to ACM, you might want to check this little switchjumper on the VFD (last pic), , assuming you have a Huanyang VFD or similar

DUDE!!! You did it!! lol. Omg so simple. I moved the jumper, and boom, works almost perfectly.

Now, only other thing I notice, is when I power the VFD on, it immediately runs up to 6k rpm. I give it a command of say M3S12000, and she spins up, I can adjust speeds with M3 commands even though they seem off by about tthe 6k rpms. But, if I hit M5, it drops down to 6000rpm and stays there. I can’t actually shut off the spindle. I assume thats a VFD setting I must be missing.

I should also point out, I am still only getting that weird curve of 0-2.1-0 voltage

1 Like

Well here is a completely new development. Complete loss of all control. I can’t reset to factory settings, I can’t change P024 so I can’t shut off the spindle. I’m finding this entirely insane. It’s like I lost the ability to change any VFD parameters. The P000 is still set to 0.

EDIT: Figured out if spindle is running, no settings can be changed. I was able to disconnect my FOR jumper and the spindle isn’t running. So…now…how do I get this thing to NOT spin up to 6k immediately upon powering on?

it’s your others params, they are setup for a non zero minimum RPM. can’t elaborate now

1 Like

PD011 and PD073
is it an air cooled or water cooled spindle though ?

1 Like

Water Cooled.

I found your post from last year that details all the parameters. Found those two settings, changed em, and voila, working as it should. I now have complete control over the spindle from the computer, and it sits idle waiting for commands. Is roughly 3-400rpm variable within the accepted idea of these VFD? Not entirely concerned with what the display reads, but I’ll have to measure the actual spindle at some point.

1 Like

Good that it’s working now. I’ll be bookmarking this for when I try to connect my HY VFD up to the controller.

As for the spindle speed vs the indicated speed on the HY VFD, the display will be quite accurate in regards to the drive frequency and speed, it appears to be internally derived from a clock crystal.

However… the spindle speed will never be quite the drive frequency, that’s how these motors work, they need a “slip frequency” where the shaft runs about 1% to 5% slower than the magnetic field goes round in order to induce the current in the rotor and give them torque.

You can configure the HY and other drives to automatically try to adjust the drive frequency in response to the increasing slip as the motor loads up, but I don’t think that’s worth it on this size of machine. Your slip freq is only likely to be 1% or 2% anyway at the cutting loads we can hit on a Shapeoko.



Yep, that.
We have a thread somewhere on tuning $30/$31 and/or VFD curves to finetune PWM to spindle RPM, for 300RPM is not going to a significant difference in 99.9% of our usecases, I would not bother.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.