VFD turns GRBL into a potato on start

After a bit of a hiatus, I’m back in the shop. I got my spindle installed and VFD hooked up. Everything seems to be going well… That is until I turned on the VFD. The instant I do the GRBL checks out and refuses to communicate to carbide motion until the VFD is turned off and the power to the GRBL is cycled.

Also, I haven’t figured out how to start the spindle with carbide motion. But that’s another story.

A cursory search here came up with a few similar situations that others have tackled and I have followed, but from what I can see, no definitive solution to the problem.

Anyone find their way through this and discovered a solid solution?

If this is the C3D VFD and spindle talk to support. If it is a 3rd part go back to the hook up and make sure you are on the correct pins. If on the incorrect pins you could be killing the power supply when the VFD is turned on.

If you have the C3D VFD then for the VFD to be controlled you use the Shapeoko post processor and when running through the setup you tell the config you have a C3D VFD. By using the Shapeoko post processor in CC the correct gcode commands are embedded in the gcode/.c2d file.

Thanks, I appreciate the reply. This is an aftermarket set up with an aftermarket VFD and spindle. I looked into the power loss idea and the unit doesn’t appear to loose power as the LED in the GRBL don’t go out. I kept my volt meter on the power rails to verify and power doesn’t seem to drop.

The more I look into the cause it seems something is killing and or nullifing the communication system in the USB connection. Since I cannot reestablish communication with the GRBL without a power cycle of the GRBL and not power cycling the computer, I suspect the issue lies in the GRBL. I’m going to try a USB isolator and dig into it further.

As far as the GRBL controlling the VFD start and spindle speed I’ll need to look further into how they connect their VFD and see if that method is compatible with this VFD.

GRBL itself is just the software running on the controller. Chances are the controller is seeing a massive electro-magnetic interference spike when you turn on your aftermarket VFD, which glitches the processor and then communication is lost. This can happen when something in the setup is not properly grounded, so the voltage spike finds it way into the controller electronics rather into the ground. There are tons of (now old) posts about this, but there is indeed no definitive answer just because everyone’s electrical setup is slightly different when they are not using a fully-C3D one

USB isolator is worth a shot, but your problem is more likely located on the electrical path somewhere between the VFD and controller, not between the controller and PC.

Check if your VFD is properly grounded.

Try and just disconnect the PWM interface between controller and VFD, turn on the VFD, see if the problem persists.

Try plugging your VFD into a different socket than the machine.

The excellent news is that the problem is repeatable in your case. Intermittent EMI problems are different beasts.

1 Like

What machine is it. And how are you connecting to the pwm signal?

Sorry about the delay in my reply. Work keeps me rather busy.

I’ll do my best to answer the questions and what I have done this far.

Everything is grounded. I even grounded the frame of the machine. I checked inside the spindle and even grounded it again regardless.

Yes, if I disconnect the analog input to the VFD and activate the spindle via the panel potentiometer the unit disconnects and will not reconnect until power cycled.

The VFD is single phase. And it uses a dedicated outlet.

A side note. My USB isolator should arrive tomorrow. So I’ll post an update then.

1 Like

Shapeoko XXL

I connected the ground and PWM to analog voltage input COM and VL1/C1

I soldered a JST-XH connector here and use a plug.

Try using a laptop or tablet to control the cnc. Does it do it with no power cord plugged into the laptop?

I had this issue. As soon as my spindle powered up it would disconnect. Only with the computer / tablet plugged in. Would do it with an ups. Would do it with a generator powering the laptop and everything else.

I tired usb isolators, and all sorts of stuff. Never was able to fix it. Ended up buying. A $100 refurbished tablet to run the machine in plugged.

Hooked solely to my laptop through only the USB with no power supply attached to my laptop, it still disconnected as soon as the VFD started to spin the motor.
It’s looking like the VFD is the culprit.

A test I did sheds some new light on my situation. Here are the steps I took:
I initialize the machine.
Disconnect the USB from my laptop.
Turn on the VFD and spun the motor up then off.
Connected the USB

I could connect and reinitialize the device.

If I run the VFD and motor then stop it with everything connected, I cannot simply disconnect the USB and reconnect it to reestablish communication. Windows gives me an error.

Whatever’s going on directly affects USB communication.

It is likely EMF being generated by the VFD. Some people have reported here on the forum that if they use GFCI outlets to power their VFD it will pop the GFCI. I have two lathes and one is a variable speed and the other has variable speed but is a VFD. If I hook either one up to a GFCI outlet it pops the GFCI if I change speed. I made a single outlet circuit in the shop to run those lathes on. When a VFD (Variable Frequency Drive) they change the motor speed by varying the frequency of the motor. That changing frequency can introduce noise on the electrical circuits and as you said “It’s looking like the VFD is the culprit.”

Now the question is how to fix it. If you have a UPS I would try that to see if it isolates the input and output voltages. If you dont have a UPS maybe just a noise filter might work. Not sure if you had said you had this VFD on another circuit from the machine/laptop but that might also work. A separate circuit might work but all the 120VAC and 220VAC circuits are on a common bus inside your electrical panel.

I know this is cheating but if you have a local store that caries UPS buy one and if it does not fix the problem return it. Amazon and Walmart both take returns very easily.

1 Like

I apologize for the multiple replies.

Alright. This is weird. But in a good way.

At first I tried grounding everything, now I did the exact opposite. I isolated everything for this test. The shapeoko controller power supply was supplied through a battery powered inverter. The controller was removed from the shapeoko body and disconnected everything to it except power supply and the USB that was attached to my laptop which was running on its battery. Turn on the VFD and the unit disconnected… At this point there’s only one culprit left, EMI.

Fortunately, I have encountered this before and I have a fix for it.
I’ll let you know what I did and what to get if it works the way I believe it will.

Oh, apparently I replied to you by accident.

Alright. It took some digging and a lot of verifying with lots of research.

This is my working theory that I have so far with the spindle causing USB communication loss. I believe have it tracked down to the ADUM4160 chip on the board. This chip is a USB digital isolator. This chip uses air core transformer to “transmit” information across a isolated gap via radio-frequency currents. This in itself creates low level localized EMI radiation. That said, it’s also susceptible to it. Air core transformers use confining magnetic flux facilitating maximum flux linkage between primary and secondary coils in this chip it uses that communicate data. EMI radiation that hits these coils scrambles the data packets to the buffers and the chip just gives up.

I have ran this across several other electrical engineers and they pretty much all agreed. One guy never got back to me. Now the real question is what can be done about it.

These “cheap” VFD blasts EMI out like chernobyl. The ideal situation would be to not make the EMI radiation in the first place. An industrial grade $400 - $800+ Allen-Bradley 25B-D6P0N104 Powerflex 525 would likely do the trick, but that cost… Ugh… Another thing I found is this particular EMI source seems to lose energy at a distance. For me, roughly 3 feet between the board and the VFD did the trick. I verified this by moving the board away from the VFD and it held it’s connection. I could see about doing something about the chip itself, but reengineering the board doesn’t seem like a worthwhile project as newer devices exist. Another way would be to reduce the amount of EMI at the source with ferrite cores. So far I found that’s akin to nailing down jello. The EMI appears to be coming from the unit itself, not the wires. Putting the VFD into its own Faraday cage may also work, but I haven’t tested that yet. Another option is board level EMI shielding, if you’ve ever repaired a cell phone you’ve seen these little boxes certan chip sets are covered with. There are a few options to try. Once I have a viable fix, I’ll report back.

3 Likes

You have found out the hard way what this guy on YouTube has been preaching for a long time.
VFDs belong in a separate metal cabinet, not in the same cabinet alongside all the sensitive control electrics.

2 Likes

All right. Then I won’t bother posting a solution.