Weird ShapeOKO 4 behavior after using grbl-controller

I would like to get some input on this. I used grbl-controller on one of my android phones to control ShapeOKO4, they seem to work fine together, I can use the app UI to move the machine, but did not try cutting anything.

However after I reconnect ShapeOKO4 with Carbide Motion on my mac, and initialize machine, the machine found the bit setter, but started to go all the way up to Z limit until it hits the sensor - sensor does light up and machine then moves down to regular position. I tried to jog it, with max stepping, all direction buttons XYZ± are moving X axis minus direction, which is super weird. This does not happen if I set the stepping to 1mm, and quick position works fine, too. I switched several Carbide Motion versions, and tried different USB cables, all the same behavior.

To eliminate the possibility the PCB is fried, or too much dust caused a short circuit, I vacuumed the machine and used keyboard spray can to blow off dusts. This does not fix the behavior. However when I plugged the Android phone back to the machine, grbl-controller can control the machine.

Based on the behavior I don’t think this is a connection issue, or circuit issue. My best guess is that grbl-controller might did some settings that somehow persisted in the PCB.

Why not send the configuration from CM. It wont hurt and may short circuit all the guessing.

1 Like

thanks, after posting I tried several other ways to reset, and it seems working fine now, at least I can move the spindle with 1mm steps and run an nc file to cut simple things.