Well I did it. Just purchased the 2x4 5 Pro with VFD

Here in SW Ontario Canada. Looking forward to getting my new machine. Now time to build a nice workstation for it to sit on and find a computer to put motion on.

Plan to post pics of the install and first start up… Here’s hoping all goes well.


Good luck to you. I have a cheap laptop coming to set along side mine. Amazon has a bunch under $200.

What laptop did you go with?

I picked up a refurb HP with an i5 processor. Should be more than enough to run the SO5.

Related, I never thought I’d say the words “my garage computer arrived today!” :joy:

1 Like

I picked up a clean refurbished Surface Pro (I5, 8GB) with the Surface Keyboard and Pen for $150. Works great as a dedicated machine in the workshop (garage) running Carbide Create (Pro), Carbide Motion for the 5 Pro and Laser GRBL for my laser machine. It also runs a lot more, for when I’m sitting baby-sitting a project in process. No complaints here - my 5 Pro (2x4) and Carbide VFD spindle are both performing like champions. I’ve completed both wood and aluminum projects, as well as some PCB engraving and drilling with Carbide Copper.


That’s awesome. The exact same machine I purchased. Still in the boxes as I need to build the table for it. I will check out the surface pros for sure!

I got a good deal on a Harbor Freight hardwood workbench. I modified it by adding a deeper top of 3/4 board with the rear overhanging edge fixed to the wall with a length of scrap angle iron cut from an old bed frame, and a couple of coats of PU varnish. I have no space to make a moveable machine table, and this works great for me. Made for a very solid support with three nice felt-lined drawers for storage and a raised space underneath for wood pieces etc. I couldn’t buy the hardwood and fittings for anywhere close to the price of the finished bench, so it was an easy answer.

1 Like

I keep looking at that (and regretting the on-going price increases).

For folks who aren’t familiar:


I went with:

which has worked out about perfectly.

I got this workbench new when it was on the 20% off deal - so around $150 after tax. I actually have another older version (came secondhand from a friend who moved to an apartment) that supports a Mini-Mill that I converted to steppers and ball screws a long while back. The drawers on the new version are a lot better, with decent slides.

1 Like

Just put my 4x4 Pro 5 together today , haven’t powered up, but confused if I need to plug the spare limit switch in , just got one and not sure what to do with it, sorry in advance for possibly dumb question

Not a dumb question at all. We are all new at some point. I believe I saw somewhere that they ship an extra one. Not 100% sure. Someone should chime in pretty quick.

1 Like

I suck. Canadian guy here so everything is quadruple from what you guys get :wink:

1 Like

Yep, they included spare one. Good thing too, since the right rear Y on the machine had no connector (bare stripped wires only), so it got used immediately. I’ve since put a connector on the original one so it’s back to having a spare.

I went thru carbide motion setup, everything went smooth, I have no Jog buttons , using vfd spindle, seems like it goes too far to the front and to far down when i hit initiate machine. no file loaded, have yet to hear spindle run, watched videos, tried to uninstall motion and reset machine now have homing error 8

Jog only appears after the machine is successfully initialized.

Were you able to complete machine configuration?


for Grbl errors see:


for addressing homing issues see:


if you continue to have difficulties, let us know at support@carbide3d.com and we will look into them with you.

1 Like

Yes Everything moved perfectly thru the setup wizard and said finish after I saved setting per each step. then took me to main screen and no jog. Can I clear cache and reinstall?

On my CM I have to initialize (yellow button?) before jog appears. Did the machine initialize?

1 Like

ok got irritated, unplugged everything and restarted everything, now I haver jog commands. I think I need to reset bitsetter center , that is tmrw project, out of juice today. any extra advice appreciated.

well it looked like bit was gonna go too deep in bitsetter, so I hit E-Stop on pendant. and back to square one. no Jog etc. my patience has had enough today. Sure its something silly in front of me , but at this point, its supper and bed.

We have an article on too-deep plunging at:


If you’ll put up the .c2d file, step-by-step notes on how you are securing your stock and setting zero relative to it and managing all tool changes, and a photo showing an attempt at cutting still in place on the machine we should be able to walk through this with you.