Whats going wrong

I have no clue
I load a drawing and create my toolpaths, run simulation and all is well
I then tweek my settings-stock size, thickness and from shapeoko 3 to XL
run my simulation again and geometery is missing-hopefully jpg’s uploaded to see
change settings back and toolpath is ok again, anyone know what’s up?

I uploaded the gcode (below I think)

I have been able to run everything else I’ve drawn, maybe with an extra hour or 2 tweeking but this one I can’t figure out.

4x4 pencil run.egc (2.9 KB)

Post the .c2d file as well?

I’ll try, but will have to be Sat or Mon.
There was also a thought of doing the setup first in create and then import, will give that a go as well.
Newb at this so bear with me, was amazed I even ran some things with no major hickups, nice machine.

Framless 4x4 redraw.dxf (176.1 KB)
this is the file drawn in autocad
tried a multiple senarios and all the same; all is well until I change the stock size, even an inch

thanks for your time


just uploaded your file, looked great until…I changed the stock job setting, lost geometry in tool path

went back to your job setting stock size, looked good again

until…I changed the stock thickness, all looked great but tool path #5 had missing geometry on right side.

maybe my board is screwy?

Please see if the problem is repeatable after a reboot. If it is send the file with the steps to cause there error to Support

I’ve gotten it to work, well you have (thanks)

as I’m extremely new at this it had to be something I’m doing, just not sure what that is yet.

thanks again Will for your time and patience

Our pleasure!

SVG import seems more reliable than DXF, but wants:

  • closed paths
  • no overlaps
  • correct winding
  • nodes at extrema
1 Like

Had anyone tried cloudconvert for this conversion?