Win 10 tablet works!

  1. bought $67 dollar NuVision Win 10 Home 8" tablet, and after a few fits and starts, just got it talking with/controlling the S3 ! (NuVision Model TM600W610L); just jogged it around some, have not done a job yet
    .
  2. downloaded a couple g-code senders, but the UGS connected/worked with no fiddling, unlike the other couple I did not want to spend more time on tracking down solutions when something else works out of the box
    .
  3. had to download java, too, as that seems to be platform for a lot of these reader/sender progs
    .
    saves me dragging the laptop out to the shop, knowing one day I was going to slip, dogs were going to get underfoot, or otherwise blow up my main working computer ! AND, for bonus points, works fine while in a Ziploc bag (yeah, dust collection is next on my to-do list, just got a Dust Deputy for solstice)…
    .
  4. completely unrelated: as a long time wood turner, but newbie CNC acolyte, I will pass along an old turners tip to hold work pieces securely while turning/machining:
    (NOTE: I have done this with regular wood turning a bunch of times, but NOT with a CNC project as of yet, YMMV.)
    Tip is to take a waste piece of wood, your work piece of wood, and glue them ‘together’ with a piece of newspaper/regular paper in between them. After the machining is done, you can fairly easily take a (non-super-sharp) chisel, and whack it at the paper boundary between the pieces of wood, should separate cleanly with a sharp rap or two.
4 Likes

Did Carbide Motion not work on this? It should — I’ve had good luck w/ Windows tablets controlling my machines.

day-am ! what was that, all of 10 seconds after I posted that you responded ?
You are a TREASURE to the cause, Mr. Adams…
.
Answer is, NO, could not get Carbide Motion to work. Kept up with the ‘missing DLL’ stuff, and simply would not get around that after 3-4 re-installs, updated Win 10, etc. Wanted to use that as it is what I am used to, works, etc; but no go so far.
.
Any tips appreciated (already tried most of the suggestions about re-loading the VB dll’s etc, and no go.
THANKS again.
.
(The other complication is, just getting ready to install a laser engraver, upgrade GRBL, etc, so wonder if anything will blow up that will cause this arrangement not to work then. Will cross that bridge when I get to it.)

1 Like

Oh, also meant to say, love, Love, LOVE the touchscreen interface for use in the shop, simply a million times better than a dust clogged mouse, etc. Have a Bluetooth keyboard if I need it, but the onscreen one is fine for the limited use of basically sending the gcode file to the machine. Don’t do any development or anything on the tablet, simply using it to control/send files to the CNC.

Darn.

Usually they work — we’ll have to see if we can get one to a developer and have them solve how to get it working.

I just solved the .dll on a laptop. Had to install both 32 bit and 64 bit versions of c++.

1 Like

Was it complaining about msvcp*.dll, msvcr*.dll and others? This is usually why you need ton install the C++ redistributable. The other option for Carbide 3D would be to statically link the libraries to avoid the requirement for the dynamic libraries. This is usually specifying /MT instead of /MD to the MS compiler or if using Visual Studios to build the option is under properties -> C\C++ -> Code Generation -> Runtime Library.

FWIW, there are some notes on this at:

https://www.shapeoko.com/wiki/index.php/Carbide_Motion_Machine_Control_Software#Dependencies

(which arguably I should have noted before)

1 Like

Also unrelated to your Win 10 issue, have you heard of the masking tape/superglue holding method? Same concept as your newspaper method, but in this case, you put masking tape on your work piece, masking tape on your scrap piece, and then super glue the two masking taped surfaces together. Super glue won’t let go when you are done, but the masking tape just peels right off. I will say that you have to be careful when cutting all the way through your work piece, as the masking tape can gum up your bits some.

3 Likes

The main thing keeping me from getting one of these sub-10" tablets is that they don’t ever seem to have separate ports for power and USB, so if I want to use it to run the Shapeoko I have to charge it separately and then switch the cables.

But in every other respect, this thing looks really nice.

An excellent point, which I always worry about forgetting to make.

I will note that the Toshiba Encore 2 Write 10 I use is able to use a Toshiba adapter which has a Micro B power in connection, and USBA out, so it can control my SO3 or Nomad while plugged in. The wiring for this is weird though, and while I did get a USB hub for my Asus Vivotab Note 8 which is supposed to afford power in while connected to the OTG Micro-B port, I never tested it.

Fortunately, my Samsung Galaxy Book 12 dispenses w/ such issues and has two USB-C ports.

Excellent variation on a theme, um, Rogue, er, Adam, whoever. Nope, had not heard of that one. I guess a little more prep, but less chance of splitting wrong at the boundary of masking tape than paper.
.
Also, thought I had tried loading both 32/64 bit dlls, but I will go back and double check. Frankly, not that huge a diff betw most of these sender programs (er, apps, age is showing), so whichever one works firstest out of the box with the least fiddling, is what I will end up using.

ahhh, yes, now I remember: I DID -in fact and in deed, your honor- try to install the 32 bit versions as per the link in the wiki page you have cited, but when I go to install, it pops up a Micro$oft msg that that version can not be installed on my machine, go piss up a rope. (The go piss up a rope part is automatically implied with M$ 8^)
.
Just tried it again, and same message, not sure where to go from there. I guess check laptop which runs Win10 with C-Motion okay, and copy the DLLs in question from there over to tablet. Hmmm, a roll of the dice.
.
Thanks for help, peoples.

this worked for me in june 2020 with a chuwi hi10x windows 10 tablet. downloaded the x86 c++ redistributables and mine worked after having the dll problem.

https://support.microsoft.com/en-us/help/2977003/the-latest-supported-visual-c-downloads

2 Likes