Wont connect etc. HELP!


I am waiting on tech support currently but hoping this great community can help a guy out. Here’s my problem…

I built the machine and made sure to triple check all the wiring etc. Everything is connected according to the instructions and videos I’ve watched to make sure…

I start up Carbide motion via Microsoft surface! (most recent version on their site). I then turn the machine on and wait a min for it to boot up. I plug in the usb and hear the chime. I then click connect and it gives me 1 of 2 problems. It either says "cannot open port for cutter. serial port: unknown error, or it just crashes CM and I have to boot it up again.

I have uninstalled and reinstalled CM and the same issue. Every 20 tries or so I can get it to connect but then I run into the next wave of issues.

I go through the settings and set up the way I am advised to do so with the XXL etc. I then save and configure. It then says I have to initialize the machine. I click the button and 2 seconds later the machine stops moving and tells me “GRBL Error: Homing failed, couldn’t find limit switch.” I click it over and over and have the same error.

I checked the limit switches all of them are working fine. PCB lights up and so do the switches. Also reset the PCB and same issues all over again.

I Then have to reset the machine and the same non connecting issues comes up and the same circle over and over. I am super disappointed and frustrated with the situation. I spent a lot of time and money on this machine for it to not work from the start. ANY help would be greatly appreciated. I have attached several pics showing my PC board connections and the error alerts.

Please see:


If that doesn’t work let us know at support@carbide3d.com

I would love to have a homing issue right now. I figured out that I needed to select z plus when setting up settings. That was of course once I got the machine to connect. It took 20 tries before it just connected. I was able to run initialization once I selected the right model. The initialization ended with the shapeoko In the bottom right hand corner. I then clicked jog And carbide motion crashed and I’m not able to connect again. Homing switches seem to be fine now all three show up in the LED circuit board and all flash red when checked. Could you please help me try and figure out how to get this thing to connect. I’m using Microsoft surface 4. I’m also using the supplied USB cable. I don’t get why it connects 10% of tries

Is the USB cable running near any power lines or along anything that might be creating magnetic fields, or even potentially static electricity? Do you have another USB cable you can try.
Sounds like the issue here is probably either the USB cable or one of the ports that the cable is plugged into.

1 Like

Not that i can tell. The unit is in my garage and nothing to cause interference. The cable is the one supplied right out of the bag. Are there more then one port to plug into? I only see the one beside the power plugin.

The board only has one port. I wouldn’t know how many ports the device you’re plugging into has.
There is always a chance that there could be a bad connection in the USB port on the board, or it could be a problem in the cable, sometimes USB cables have faulty/broken wiring.
I believe the USB cable has the same connectors as most printers, so if you have a printer cable laying around you could probably try that out.
Unfortunately I wouldn’t know how to check the port on the PCB.

1 Like

I’m going to buy a new cable. Fingers crossed

Do you have another computer to try? This could eliminate an issue with the Surface, or show that the issue is the surface.

1 Like

c/p from the Carbide3d shapeoko page;
All included software runs on your Mac (10.9 or higher) , or PC (Windows 7 or higher) .

Running surface pro 4 which uses windows 10 pro.

That’s not the issue

Not the cable. Tried a new one I just bought. Nothing. It connects 1/30 attempts if I’m lucky. Tried a new computer too. Seems like a mother board issue. I just don’t get why it connects at all when it does. Every time I can get it to work it makes me re initialize it and after that’s done if I try and jog the machine it crashes CM and I have to start all over again. Sometimes when I try and connect I get an error message and majority of the time it just crashes CM and I have to re open the program. Frustration level EXPERT

I would have to guess if it is the board at fault, and it sounds like that’s the case, there must be one connection that is just a little flaky and works only some of the time.
I’m relatively new to all this stuff, but every time I turn my CNC on I have to re-initialize it, so I think that’s just a normal process there.

1 Like

Please let us know about this at support@carbide3d.com

Include a step-by-step list of all the things you’ve tried so we can leapfrog some of the script and resolve this more quickly.

I’ve figured out my Initialize problem but I can’t get the CM to stay open. It just crashes. Wont let me connect 90% of tries. Bought a new USB and still won’t work. Using a Microsoft surface pro 4 running windows 10. Should be more then sufficient. Someone mentioned an update you guys can send? I did all the windows updates available last night and still won’t work

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.