X and Y issues please help

Hello everyone. I am a “newbie” so please be patient.
I had a few issues when I purchased the CNC but Rollie was able to get me up and running. The machine has been doing very well until recently.He is awesome. My current issues are as follows…

(1) Sometimes I get the “Cutter not found” message when I try to connect even though it is powered up and connected to my Macbook.

(2) Occasionally, I lose connection but typically not while cutting. I believe it is usually while jogging.

(3) The machine often has issues maintaining correct zeros for X and Y. Part way through the job X or Y (sometimes both) will shift and screw up my work. It is as though a belt slipped even though the belts are tight.

(4) Occasionally, after setting my 3 zeros with the Bit Zero and after the Bit Setter has run through its cycle, my Z zero is way off. Sometimes the cutter is 1.5 inches above my work (not too awful bad as there was no damage) and other times it drives the bit into the work until the router bottoms out.

(5) Sometimes when using the “rapid position” it fails to move all the way to the left but sometimes after this happens I can manually jog the machine the rest of the way using my computer. When it stops part way using the rapid position feature, it sounds as though it is hitting something and unable to get past it.

Here is something I did find but do not know if this is a contributing factor. While the CNC is powered up and connected to my computer, I am able to move my X and Y axis by pushing on it. It takes a little effort, but not a crazy amount. Also, I have confirmed when this takes place, the belt is not slipping and the cogged pulley (not sure what it is called) on the motor is not slipping. I know this to be true because when I move it manually, I can feel the shaft turning through the back of the motor.
I’ve emailed and called Carbide 3D but that’s not working out too well. They have responded with some questions and requests for phones and I responded with answers and photos. I am really frustrated with the machine as it’s been down for over a week. Any help would be greatly appreciated.

Sounds like you might want to check your pulley set screws. Each pulley has two set screws holding it in position. Make sure one screw is on the flat area and the other one is tight as well. Also check that your pulleys and belt properly align with the idlers.
Some here like to replace the allen set screws with allen head bolts and apply a semi permanent loctite.
Be sure you have not over tightened your belts.
just something to check on while others with more experience reply more accurately.

  1. This could be EMI, or the USB cable being jostled — is it secure at both ends? I like to put a weight on it near the machine, and another near the computer to minimize its motion — which size machine do you have?

  2. Is the spindle or vacuum running when you jog and lose connection?

  3. This is most likely something mechanical. Per the machine operating checklist: Machine Operating Checklist - Carbide 3D , the basic points of adjustment for a machine are:

  1. This is most likely the mechanical issue as noted above.

Let us know what you find out and we’ll do our best to assist.

My original controller on my XXL had a flakey USB connector. I was able to minimize disconnects by adding a wire tie holder and putting a wire tie on to support the connection.

wire_tie_holder

The wire tie holder has an adhesive back and is made to put a wire tie through and hold wires.

You can buy these a Lowes and other retailers or order through Amazon.

1 Like

Thanks for all the help and responses guys. It is greatly appreciated. As mentioned earlier I don’t believe the issue is belt or pulley related because when I move the machine while powered up, (something I don’t think I should be able to do without the use of my computer) the motor shaft appears to turn. It is my understanding that while powered up you should not be able to push any axis by hand. I felt this would be a good test to see what was slipping. I expected to see the belt slip or the pulley rotate on the shaft. I did see the pulley rotate but not without the shaft. The machine is an xxl with the z plus axis. It is about 4 months old and based on the customer support, I am very let down with the Shapeoko. My first and second issues I thought might be cable related but I’m not sure because when I first hook it up it should work. Even with wiggling the write it takes several times (not a common problem) to connect. I only have one computer to try. I have not tried a different cable yet. I do like the idea of weights or cable ties to keep things in place. I am strongly considering selling the machine once I have all of the issues addressed and am able to see it with a clear conscience. I have not yet had a chance to set up a vacuum to the unit and while jogging the router is usually off. I say usually because occasionally I will surface a small part manually by simple using the jog function along with the portable keyboard I got from eBay. This always works well. I only have the jogging issues while using the rapid position function. By the way, the keyboard is about $8 on eBay and it is awesome. I highly recommend it especially at that price. Ben Myers did a YouTube video on it. I am sorry for being a scatter brain and all over the place with this message. Most of it was typed on a phone while at work during down time so it took place over several sessions. Does anybody know if the electronics could cause the motors to not lock while powered up?

If you can push your X and Y axis while the machine is turned on there is something wrong. I guess if you pushed hard enough you could get it to move but it would take a lot of force. So as stated earlier the usual suspects is the set screws on the pulley is loose on the motor. You can verify that two ways. The first way is to put a mark across the pulley and the motor and see if the two marks stay aligned during your pushing operation. If the marks do not stay lined up your pulley and set screw are slipping on the motor shaft. If they stay aligned but your axis moves then you need to look at belt tension. IF there is enough slack in the belt then the axis will slip. I would think you would hear a thumping as the cogs on the belt are slipping but if they are loose enough you might not hear the slippage. Take a look on the forum for threads about using an application on your phone and strum the belts and listen for the frequency. Sounds strange but it seems to work for people. There is no definitive adjustment of belts with a gauge or other instrument for a precise measurement that I know of.

Now if your pulley and belts are tight and the axis moves then you had better get together with support because the machine powered up should not be moving. The stepper motors are made to hold the axis where it is when just simply powered up.

So verify your pulleys and belt tension and if they seem good contact support for further troubleshooting. Be sure to inspect your belts for any broken teeth.

I really do appreciate all of the help. I wish Carbide 3D would step in and offer some assistance. I don’t know if they are getting too big too fast and can keep up, but I am really disappointed not so much in the machine, but the lack of help from the people I gave my money to. The forum is awesome and you guys are terrific. As far as the machine goes, I just had a few minutes to go out and confirm what I thought to be the case. I put a mark on the shaft, but not on the pulley side. I put the mark on the back side of the motor. With just a little force, I am able to manually move the machine and as suspected, the shaft turns inside the motor for both the X and Y axis. I am assuming the only reason I am unable to move the Z axis is because it is screw drive so it would take far more force. Does anybody know where I can purchase parts for this machine? I feel I probably need a controller and I just assume spend my money with a third party at this point. I am assuming it is not the stepper motors because that would mean 3 of them are bad. I would think I could find a controller somewhere. I don’t know if they are somewhat generic. This is incredibly frustrating. This was supposed to be a tool to bring a relaxing hobby in my spare time. It is now the dust collection system taking up space and causing aggravation even while I am at work. Does anybody know what the resale value is on one of these with the BitZero, and Bitsetter once it is fixed?

I work for Carbide 3D, so Carbide 3D has responded.

If the instructions I provided don’t work, please check in at support@carbide3d.com

The level of frustration has been unreal. This is something that should have been handled over the phone in my opinion. Typing messages in a forum is far too time consuming. As mentioned in my original message I stated the motor shafts turn when either of the axises are moved while powered up. This should indicate the problem is not set screws or belts. If either of those were the issue, I wouldn’t see the motor shaft move.

If that is more convenient for you, Call support. They will work with you over the phone…or at least they have with me in the not so distant past
(310) 504-3637 (9am - 3pm, PST M-F and 7am - 3pm PST on Saturday)

They don’t answer when I call and they don’t return my calls. Also, believe it or not I am an easy person who doesn’t usually get worked up. This has just pushed me over the top. It is a sad situation. I greatly appreciate you reaching out and providing me with the contact information.

Not a problem. Don’t give up just yet. Between willAdams and Julien you will get plenty of help here. This forum has a lot of very experienced people (not me) who can help you tremendously.
While the issue you describe is an odd one, it can be fixed.
also, and I know you probably don’t want to read this again, but as described above, take a marker and draw a straight line across the pulley and motor shaft and check again. Just because you can see or feel the shaft rotate at the rear does not mean it is not slipping. That line will tell you something and eliminate at least one possibility…give it a try.

Hi Peter! I am working on getting some help for you now. As I had mentioned over the phone, I will get you some technical support today. Thank you for being so patient. I will make sure to get you back up and running quickly.

2 Likes