X Limit Switch error

I just got my XXL setup and am having an issue where to X switch is always on. I tried unplugging the switch on the controller unit to try and possibly reset it but didn’t work. I tested the Y and Z with a wrench and they seem to work. Any help would be greatly appreciated.

Are the wires in the same order as the others in the connector?

1 Like

They are. Black Red Blue for both X and Y. Z has Black Red Green.

Tried swapping it for another axis?

I swapped it with Y and X is still on. Testing Y still works. So what you’re thinking is I have a bad X switch?

Huh? You moved the X limit switch to the Y plug position, and the Y plug to the X position, and??? You state: “X is still on.”

So are you saying that no matter WHERE you plug the X-Axis limit switch, the light (on the limit switch) stays on? (The should turn on when you move a piece of metal close to it…

EDIT (ADD) What King of limit switched do you have (Micro or Proximity Switch)

Yes I moved the X limit switch to the Y plug position and then the Y plug to the X position on the Controller Unit (edit). The X limit switch is still red when powering on. No matter what position I plug X switch into its on when powering on the machine. I’m using the Proximity Switch.

The Y and Z function as they should. They are off and are switched on when putting a wrench close to them.

Your problem stayed with the position and not the sw. That tells me your switches are good. If the x sw was baf the problem would have moved to y.

Check wiring for a pinch or connector for the x wires. Double check you are plugged onto riser board correctly and riser is plugged in all the way with no pins bent.

1 Like

Are you saying that the light on the physical x switch is always on no matter where it is plugged in or that the controller thinks the x axis switch is on no matter what switch is plugged into the x spot?

I think maybe I’m not using the correct language so I appreciate the patience. No matter what “port” on the controller I plug this sensor into its always glowing red when powering on.

I did make sure the riser was completely inserted as well.

Thank you!

1 Like

If the X-axis switch stays stuck on, then let us know about this at support@carbide3d.com and we’ll get this sorted out.

Definitely a problem with the switch. Support will take care of you like @WillAdams says.

Isn’t that switch right against the metal of the axis plate? There’s no way it will turn off it that is the case.

I recently did this upgrade and all the switches were moved away from the metal by plastic risers. I just checked the document (quickly I admit) and can’t see an X switch mounted in this fashion.

1 Like

Here is a comparison side by side of the X swtich

I think the pic above the bottom of the switch is 90 degrees off. It should be pointing down at the gantry/drag chain. Maybe it is just perspective. The pic on the right is from my own machine that is working. However the red light is on on the left without any triggering from metal.

Mine looks like yours, Guy… here’s the pic from the instructions:

1 Like

The picture from the instructions shows why so many people have trouble homing on new machines. Notice how high the switch is located. This position usually has to be adjusted down to get it to trigger on the side frame. My comments have nothing to do with this thread just an observation.

So I think we have two different ways of installing the X switch. Here’s my instructions. I contacted support and they overnighted me another switch and it worked perfectly. Shortly after I was able to print the Hello World Shapeoko logo. Thank you everyone for the help!


Correct. The original homing switch mounts were metal plates and spacers and other hardware, current production are injection molded.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.