XL doesn't home after long x travel

I’m having an annoying problem with the S3 XL homing. When I start the homing cycle when the spindle is at or near the left side of the x-axis, it homes and hits the limit switch pretty quickly on the y-axis but stops about 6 inches short of hitting the limit switch on the x-axis. I then get a message saying ‘cycle aborted’. If I’m not too far from home on the x-axis (e.g. in the center) then it homes correctly. I have to send G-code to the machine to get it away from the limit switch on the y-axis (G0 G91 Y-1) before it will home again. I thought that perhaps the process was timing out so I sped up my homing speed considerably ($25=2000). It moves faster but consistently stops at pretty much the same spot on the x-axis. The X limit switch isn’t being hit somehow (I checked the controller during the homing cycle) and it will home normally if it isn’t too far away. 1006 = 840 and 1007 = 430.


That’s pretty odd.

We have a basic page on homing switch troubleshooting at: http://docs.carbide3d.com/software-faq/home-switch-troubleshooting/ but nothing seems to apply.

Increasing $25 to 1500 is the suggested fix and I believe faster is used in CM4/Grbl 1.1, so 2000 ought not be a problem.

Are you able to restart homing by sending $H?

Thanks for the reply. If I send $H I get a message ‘Homing Switch Hit’ and nothing happens. I assume it’s referring to the Y switch. If I back off the Y switch (G91 G0 Y-1 a few time) and resend $H then it will home correctly.
It stops on the x-axis pretty consistently at the same spot, even after I sped up the homing speed, which makes me think that the problem is not a time-out.

In that case, my suspicion would be some sort of short or mechanical interference which pulls the wires so as to close the circuit. Are the wires long enough for you to swap the Z switch onto the X plate and X connector and vice versa?

One thing to make sure of us that you’re table size settings are right. I’d have to check later as I’m in the hospital with my son (dehydrated from the flu) right now. But I’m sure Will has where to check that handy :wink:

I know I had that problem with my xxl, and that was the issue (table size).

Here…just found the discussion that helped me:

I’m pretty sure you want $130=850 only

1 Like

Scott, I think you solved it for me. I set $130=850 and $131=450 from the shapeoko 3 XL and ran through a few homing cycles without a problem. I knew table settings were important but I thought that the 1006 and 1007 setting that are visible on the ‘Settings’ screen was taking care of it. Apparently I was wrong. Thanks for your help and I hope that your son is feeling better.

1 Like

Glad it works now! It’s not like it was a show stopper…but it sure was annoying to have to close Carbide Motion and start the homing sequence again.

Exactly, it was a pain. Thanks again.