XL Z-axis belt slipping issue

I just bought a used Shapeoko XL and the previous owner seemed to have improvised at times instead of following the instructions. The only unresolved issue is a noise when manually lowering spindle mount. It almost sounds like the belt is slipping, but I have tried tightening it and loosening it and with same result.
Please see this video:

There is no play in the assembly and the Z carriage runs smoothly on the rails. It only seems to happen at a specific point and occurs mostly with a faster movement.

Any suggestions as to what the issue is?

Is that with the motor wiring connected?

I suspect the Z-axis belt is damaged — other thing to check would be a loose pulley set screw on one of the pulleys.

Community has notes on parts availability at: https://www.shapeoko.com/wiki/index.php/Parts#Shapeoko_3_Z-axis or contact us at support@carbide3d.com or buy a maintenance kit (which will allow you to refurbish a machine to pretty much new).

Yes all wires are connected. Would that play a role?

Not sure what you mean by set screws as it is a continuous loop, but I will remove the belt completely and inspect it tonight.

Thank you for the suggestions

One other thing to check is a wire which has intermittent connectivity and consistently looses connectivity at some particular point of motion

Disconnect the wires from the motor where they connect to the controller board. See if the issue persists. That sounds like back EMF into the controller powering up the driver, and you’re moving the axis fast enough for that to occur.

Regarding the set screws: down in there is a gear and a pair of rollers - they should trap the continuous belt. There are set screws in the gear that may be loose (very often people find a set screw on their wasteboard and no idea where it came from…this is usually the culprit).


When you move a stepper motor, you’ll generate voltage. That back voltage can power the stepper driver, and briefly enable the stepper which you’ll feel and hear. That said, please don’t move it as fast as you can by hand.

I would power up and test the controls…if the issue persists, investigate more.

1 Like

We’ve tried to collect everything on testing the machines at: https://www.shapeoko.com/wiki/index.php/SO3_Function_Test

I’d really like to work up a test which included some basic cuts in typically available sample materials — also, would it be valid to put a scale on the machine, then run an endmill down until the belt skipped, noting the force necessary as a way to verify belt tension?

Inspected the belt and it looks in good shape. Also inspected the set screw for the non powered gear on the Z-axis plate and surprised that this screw is fully threaded rather than partially, but everything looked fine otherwise. I assume that the some loctite is needed here…

Wow! You were spot on, Disconnecting the motor wire eliminated it. I honestly didn’t think I was moving the Z fast enough for this to be the issue, and it always seems to occur at a specific point, so I assumed it was mechanical rather than electrical. Thanks Neil!

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.