XXL not recognize change in stock thickness

Changed from .77 inch thick stock to .49. start new job and cutter starts 1/4" above stock. I have doubled checked the depth of cut the thickness of the stock both show .49. Only other change was from 1/4" end mill to 1/8" end mill. I also closed everything down and started up next morning still same issue. thinks it has .77 stock This just started as I’ve made about 50 projects so far and I come in to the shop yesterday morning and this happens.

Looks like you just have to put a 1/4" waste board under your stock, and you’re golden.

Your statement lacks any information to come up with a solution to your problem,
XXL? 3, 4 or Pro?
is the new job the same as the old job, just thinner material?
What software did you use to create the toolpath?
When you changed stock, did this also mean you also created a new gcode file for the new stock?
Where do you define your Z zero, at the bottom of stock, or the top of stock?
are you using a Bitzero?

Where did you set zero relative to the stock? How?

Is origin set at bottom of stock or top in your file?

Using XXL 3 started a new job new file and thinner material toolpath created using carbide create and created new gcode Z zero is at top of stock not using Bitzero but sheet of paper.

How long of an endmill are you using? What happens if you start by setting zero using the shortest endmill?

After doing so, are you then able to move the machine down to reach the bottom of where you expect to cut?

Zero set at top of stock as I have for the last 50 projects or so set thru carbide motion

Can you restate what you’ve done once again?

It’s not clear if you’ve made these changes physically (put a thicker bit of wood on the machine) or in software.

in the setup I changed from .77 stock to .49 then clamped a .49 piece of stock to my waste board and it still thinks it has ,77 stock loaded.

Since you zeroed to the top of the stock, it wouldn’t matter if you had 4" stock or 1/2" stock. It wouldn’t cut above.

It doesn’t know what sort of stock you’ve attached to your waste board.

We probably need to see your .nc files to see what might be happening.

my 1/8" end mill protrudes 7/8" past collet nut and yes as I set zero I touch the top of the stock.

Do you have/use a bitsetter?

Yes I use bitsetter have since I purchased machine

Okay - then we have a possible reason.

When using a bitsetter you can never change the endmill unless there is a prompt in Carbide Motion saying that you should do so.

This “never” is a true “never”.

How would I post the nc files?

my process is to initialize machine it asks to install a bit I put in 1/8" end mill it then touches the bitsetter I load the job and start job it asks to install 1/8" end mill as the job calls for I tell it to resume it touches bitsetter again then asks to turn on spindle and resume starts the job This has worked fine for the past 3 months now it doesn’t.

At what point in this process did you set the zero to the top of the stock?


sorry, after touching the bitsetter for the first time I jog over current X and Y location and set zero on z.

You mentioned you switched from .77 stock to now.49 stock. Did you set your zero again after changing stock to the thinner stuff. Go in the jog menu and jog over to your X,Y,Z position so it’s at 0,0,0. If you are .28 over the corner of your .49 stock then you need to redo your zero when changing stock. Just mentioning it since you did not clarify above if you did this or not.

Edit: I’m just wondering if you mean you changed the stock thickness in your CAD/CAM software or using same .nc file and changed the stock used in real life in the shop on the machine.

Yes I did that. It has worked for 50 or so projects, I don’t think it is a procedure issue but a controller or gcode problem.

I changed thickness in CAD/CAM software saved new .nc file changed stock from.77 to .49 on the machine.