Y axis motors chattering- Fixed!

New to CNC and it’s been a long road getting here. When I first got my XXL it seemed to work OK but went to heck quickly. Being new it took me a while to figure out where to even start. I’ve been trying to get a good circle but it’s always slanted to the upper right and more of an oval.

Today I worked with it again, ran it without stock and the noise of the router and could hear the y axis motors chattering, like they were taking huge steps and making the y axis vibrate badly. At the top and bottom of the circle they actually stop turning. As it continues to the vertical you can hear the y axis motors increase in speed, they sound like a sewing machine speeding up. I’ve checked all the connectors, they looked good, reconnecting didn’t make any difference. Earlier I found both pulleys were loose, I installed them correctly on the flats. Now I don’t know if I have a control problem or a motor problem? Any thoughts would be greatly appreciated.

For stepper motors, horrible noises usually indicate a bad connection — please check the continuity if you can (do you have a multimeter, or a friend who has one?). Unfortunately, losing a connection while powered is one of the things which can kill a stepper driver.

The motors are quite reliable and hard to damage, so not likely to be the problem.

If you can’t test the continuity, contact support@carbide3d.com — we’ll send you a set of extension cables and if they don’t fix things, we’ll have to look into a board replacement if it’s not a bad motor.

Other things to check (in addition to the pulley set screws you already did):

  • Y-axis belt tension — occasionally uneven belt tension can cause odd behaviour
  • V-wheels (I always forget to mention these)

When you break it down to a specific axis the machine is pretty simple.

1 Like

Thank you!!

Checked both cables from the board to the motor connectors, all are shorts. Moved both connectors a little as I checked and never lost the tone from the meter.

There are reproducible binds when manually moving the X&Y axis approximately every 2 3/4". I found those early on, did a quick measure of the wheels at 7/8", quicker circumference calculation at 21/8, 2 5/8. Something I kept in mind but it didn’t seem to be the cause I was looking for.

The belts are tensioned per the assembly instructions, looped through the bracket, cogs engaged, close enough so the screw can engage the threads of the mount bracket. With no specific CNC experience but general experience over the years they seem right.

I’m not a novice at machining but am at computer control. This frustrated me for months until I thought yesterday about running just the CNC. That was my first important lesson learned, separate the cutter from the control portion when I have problems. I posted a video here which shows the y axis motors stop as they reach the top and bottom of the circle, you can hear the sound they make and sorta see the vibration of the cutter.

1 Like

Okay, one of these days I’m going to wrap my mind around the whole electronics thing.

ISTR someone posting about similar difficulties on circles — usually EMI just knocks out the connection — not sure what’s happening here, crosstalk maybe?

Some of the EMI recommendations may help: https://shapeoko.com/wiki/index.php/Electronics#Recommendations but my inclination would be to look into grounding the router, covering it w/ a Faraday cage (I believe a couple of folks have done that), or maybe shielding the wires (or twisting them more tightly if room allows?

The router wasn’t even running, just along for the ride.

Yesterday I thought of just running the CNC portion, no router noise to mask the CNC sounds and no mill to push or pull in the stock. I’d originally used pine and thought it was jumping around because of the grain, tried willow and got the same thing,

What it’s doing is reproducible, the y axis motors stop turning (actually rotate back and forth somewhat) on the top and bottom of the circles, I’ve watched half a dozen times since yesterday, it’s on the video I linked to.

I watched the video and was thinking that it looked like normal movement (at very low speed) at the top and bottom of a circle at very low speed.

Can you run this program and video it as a comparison?

Test 3 Inch Square.egc (332 Bytes)
Test 3 Inch Square.c2d (2.9 KB)

1 Like

If memory serves, the last time this sort of thing came up it was the V-wheels (and I missed suggesting them).

As I noted before, it should just be a matter of:

  • stepper driver sends signals / current to motors to make them turn
  • pulley engages belt and moves gantry
  • gantry is guided by the V-wheels

It’s best to keep an open mind as one troubleshoots, and not make assumptions — if you can’t puzzle it out, let us know at support@carbide3d.com, mention what you’ve tried already and we’ll do our best to help.

1 Like

Have you checked the set screws on the pulleys to make sure they are tight?

Do you have flats filed on the shaft?

1 Like

To expand on Craig’s (@Lewscrew) — some of the older machine kits didn’t have flats machined on the motor shafts, so one had to do this oneself (best way to do so was to put the motor in a plastic bag, stick the shaft through the bag, use a vise or a pair of pliers to hold the shaft, file the flat, then clean up the filings before removing the motor from the bag).

As regards checking the pulleys, we do have an article on this: http://docs.carbide3d.com/article/169-shapeoko-3-how-to-check-the-pulley-set-screws

Craig- Both pulleys were loose, one wasn’t located on the flat. I turned it and tightened the screws on both pulleys. That did help a little, it got rid of the horrendous wracking in the Y axis.

Richard Cournoyer- This is the square you requested. I have been running at a very low speed trying to watch to see where this is going wrong. The vibration during the second vertical cut of he square is actual, I rested my hands with the phone on the waste board. You can also see what I call artifacts, the vertical cuts that continue above the top horizontal line. It leaves a lot of artifacts here and there.

Back to the circle, I’m still trying to get my head straight with what you said about it stopping/slowing at the top and bottom being normal. To me (as a rank newbie) to make a circle both axis would run at the same speed constantly. They would reverse as direction changed.

You did get me thinking when I read your post last night. The router makes so much noise I ran it a second time with no router. The vertical motion sounds entirely different than the horizontal. I could hear it on the phone but had to run it through a bluetooth speaker when watching on the computer to hear the difference.

For Will Adams- to me it sounds like the y axis signals are many times longer the the other 2. It shakes the machine, it shakes the router. I think it is erratic and loses location as when it made the cuts above the horizontal line in the test square. Then again maybe not because it did it on both sides??

Thanks to all of you.

1 Like

What you are explaining, in my opinion, would relate to lack of current. Since we are dealing with low voltage DC, there will be minimal effect on the length of the wires between axis on this machine in regards to timing of signals.

Another item you can check if you are able is to remove the Molex pins from the housings and inspect them to ensure they are crimped correctly.

Sometimes insulation can be crimped with the wire which will provide continuity but may limit the amount of current thru the connector. If you can remove the pins, you can also try soldering the wire to the pin, but you need to be careful to have only a minimal amount of solder as not to effect the reinsertion of pins or function of the pins in the connector body.

Also check the com port speed is set to 115200-8-N-1.

1 Like

I don’t think Carbide Motion offers an option to change the comm speed — it came out after the switch to 115200 as the standard w/ Grbl 0.9

Excellent point about checking the crimps.

Just my 2 cents id double/triple check all flats again,id also tighten all the belts,and most of all i would adjust all v wheels.I had similar issues my flats were ok but ended up being my vwheels needed adjusting.circles and squares were all funky untill i did the above.


I was referring to the settings in the computer control panel for the com port in use for the SO3.

Decided to check the pulleys again, they were tight and still on the flat. Also decided I’d tighten the belts a little more as long as they were off. The right went well. I’d tightened the left a couple of times before but figured it was a new belt stretching. Tried three or 4 times it wouldn’t hold tension and I was getting more and more belt at that end. Went to the other end, the clamp/bracket wasn’t compressing the belt tightly enough to hold it. I flattened it a little, that gave it enough pressure to keep the belt compressed.

I know I have more tweaking to do but want to thank all of you for the flow of ideas that got me on the right track.