Y axis shutter on new Pro XXL

New Pro is together after some missing parts got straightened out. When I walk through the initialization process, the X axis appears to move smoothly left to right, but the Y axis motors almost act like they’re fighting each other. The machine shutters something terrible (grinding noise) and no real movement on the Y axis is accomplished. I have double checked all of the connections (I have not checked for continuity yet) and everything appears tight and correct. What am I missing?

Is this the issue you are having

No, he needed to swap the YL and YR on the board so it would home in the right location. I can’t get any smoooth travel front to back (Y). Lots of vibration and shutter. So I can’t get a homing cycle to complete at this point…I have to turn the machine off.

Please contact us at support@carbide3d.com if you haven’t already and we’ll do our best to work through this with you.

I reached out to support by email just a few minutes ago. Thank you!!!

1 Like

@KingTut With power off, disconnect one Y motor. Power back on. Does it move the correct direction?
Power down. Try the other Y motor. What happens?

It could be possible that you have a loose connection somewhere or I’m guessing that one of the Y connectors is wired incorrectly, reversing the motor. Is the color of the wires in the same order for both Y motors? The pro uses minifit jr connectors at the board, so they’re not as easy to swap. I’m not sure about any connections along the length of the wire.

1 Like

I have support working on it, but your suggestion was helpful. When I disconnect the YL motor (and run only the YR), the machine wants to run in a normal homing sequence by moving to the right rear of the machine (although it grinds badly when it gets there). When I disconnect the YR motor (and run only the YL motor), the machine wants to home to the front right of the machine. So the X axis motor is doing it’s job consistently, but the two Y axis motors are turning different directions causing, as you can imagine, some shudder. Hope to have things solved soon! Thanks for your input.

1 Like

So, as I suspected, the wiring for one of the coils needs to be swapped. I imagine they’ll send a new harness and want pics of all of the connections on that motor.

That sounds like a limit switch issue. Does the switch indicator LED light up when you put a piece of metal near the switch?


…they did want pics and I sent those plus my findings this morning to support via email…we’ll see what they say. I haven’ tested the limiter switch, but it was lighting up at one point…I’ll need to look at that again. When I go into settings in CM the “Shapeoko Pro” settings in the travel section do not want to stay…it keeps reverting back to Shapeoko XXL. Not sure if that has anything to do with it or not. The other parameters seem to hold though.

I discovered that my Y limit switch was oriented a touch high and the gantry wasn’t clearing it. So I lowered it a touch and now it cycles back without the growling. However I’m getting an error now about pull off and a failed homing cycle. Of course I still have the YL motor direction issue but hope to hear from support sometime soon that. At least I’m covering a little ground with just the YR. Quite a learning curve…new to CNCing.

@KingTut have you heard a solution from support?


We did finally work through it. Apparently I received a test board by accident. They are suppose to ship one out to me this week. It’s been a frustrating start since they left parts out of the original delivery that took 2 or 3 requests to get right, and then this. I’m hoping this does the trick for me and gets me up and running!

1 Like

I have the same problem here. I called support and sent a couple photos. I went through everything and it’s all hooked up right. Seems like the y motors are fighting each other.

Hope I can get it sorted out tomorrow. Glad to know my issue was not the only one…at least it can be fixed. Super frustrating…

Bryan, did this get fixed? I have the same issue it seems. Thanks

Once it was determined that I had the wrong board, and they shipped the correct one, a simple install and the problem was solved.


Cool! Working with Brandon today. Thanks