Yet another issue

So Carbide sent me a completely new Z assembly, X motor, and drag chains with cabling. I just installed everything, I have checked all my connections I don’t know how many times. I’ve checked each label making sure they are connected where they need to go. I went ahead and re sent the configuration to the controller since I have all new cabling and housing. I went to initialize the machine and now it wont even do that. It just gives me an error saying it can’t find the limit switch. I’ve used a wrench and checked all the switches and they light up.

I’m at a loss. Also now when I power up the machine, I don’t get an audible “click” noise that I used to get.

Have you told this to support? People here can give suggestions but the only place you can get real help is with their support.


Yes I get that and yes I have. My machine has not functioned properly since I’ve had it for nearly 2 months. I’ve replaced this and that already. I just knew support monitors this as well.

Next step would be to check whether they register at the controller side: do the blue LEDs on the controller light up when you trigger them manually with the wrench ? If not, there is (still) some issue in the wiring.


Did that and they come on at the board

Allright, so it’s likely that the machine does not home correctly because the switch is physically positioned a bit too far for it to trigger before the gantry reaches the bumpers
Do you get a grinding noise before the error, and can you tell which switch (X, Y or Z?) does not trigger?


Does it move?..

No it does nothing, doesn’t move nothing. Just sits there

No it doesn’t move at all

@Not-Ashamed-Designs I had the same issue. What worked for me was disconnecting each stepper motor and manually moving each axis up to the limit switch. If If the switch triggers, leave it alone. If the switch does not trigger, reposition it until it does.


Just did that and nothing still
Won’t move. There are 2 lights constantly blinking on the controller, one yellow and one red. Every now and then they stop

The blinking lights signify USB communication and are expected.

If the homing switches test as working, and signal as the correct input in Carbide Motion, and if the machine can mechanically move so as to activate each switch, but the machine doesn’t move when you begin homing there’s apparently something electronically wrong, either in the wiring, the motor connector, or the controller if everything is mechanically set up correctly.

Please let us know the specifics at and we will do our best to assist.

It will not move on it’s own if that’s what your asking. This is all new wiring, literally just got it 2 days ago and installed today. It’s a completely new z motor, switch and assembly. It’s all new x and y drag chains and wiring.

The lights on the switches light up and the controller lights up blue to the corresponding inputs on the controller. I just don’t know what to do anymore. I’ve had it for nearly 45 days and have barely even been able to use the machine do to so many issues.

I’ve been emailing support as well

The folks on support should be able to work with you to determine what needs to be replaced to get you up and running.

I don’t know anymore. I’ve now replaced the z motor,
X motor, and assembly. I’ve replaced
The z switch 3 times, the controller once, now all the cabling as well.

It looks like you have a call with Fleming tomorrow. (I just sent him a link to the email thread so he’ll see it in the morning) He’s the guy to talk to and get this figured out.


FWIW, my new machine also about 3 months ago had some mislabeled cables. It would not home and had the grinding sound some have described.

To troubleshoot I followed each cable from top to the controller. I found that limit switch cables were reversed, so I switched them. Problem solved!

Before the fix, I did notice that the limit switches lighted up as the carriage tried to home, but the motors kept trying to move (grind sound)

If you didn’t, please let us know at — we need to track this stuff for QC purposes.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.