Z-axis binding after shipment: problem and my solution

Hi All,

I recently purchased a used Nomad 883 Pro from these forums. The machine is a beast and even with good packing and such… the shipping company managed to impart enough inertial force to cause the Z-axis to bind when I tried to home. -_-;


Quick update:

Since it was the Z-axis that was binding, I sought to take a look at how things were going and did the following:


  • Upgraded firmware to v1.1f
  • On attempt to home, get buzzing sound and an alarm that the door latch was not closed. (This is a US model and so has no door latch)
  • Used Arduino Serial Monitor to unlock the machine, perform manual jogging, which worked for x/y, but not for z. On performing $H to home, GRBL v1.1 reported Alarm:9, which is an unable to home. (I’m guessing it times out).
  • Contacted support via email and in these forums and tweaked some of the config settings to no avail.

Note, when I say Z-axis is binding, I mean that with power off, I cannot move the Z-axis carrage up/down by hand and manually turning the threaded rod doesn’t work. It’s literally bound.

So, after thinking about it a bit, I did the following to attempt to resolve the problem:

  • Remove right side panel(side with power and usb jack)
  • Remove the top and front lid
  • Unscrewed the anti-backlash screw drive nut from the Z-axis spindle carriage
  • Attempted to unscrew the Nema17 Z axis motor from Aluminum Z-axis carriage, but couldn’t get a good angle on it, so instead, unscrewed the stepper motor’s top plate and extracted the stepper motor core and unscrewed the nut from the ACME screw.
  • Confirmed that the Z-axis linear bearings slid without catching or issues.
  • Noticed that the threaded rod’s milled end inside of the motor did not reach the small bearing on the end cap, so took a rubber mallet to the core and shifted the rod up.
  • Re-assembled nut/rod/motor and confirmed that the rod turned freely.
  • On bolting the nut to the Z-axis spindle platform, I noticed that it started to bind when I tightened the right bolt. The left bolt is 100% tightened and I would say the right bolt is about 65-80% tightened.
  • Confirmed I could turn the threaded rod.
  • Hooked up USB and power and re-ran Carbide Motion and was able to perform homing without issue.
  • Confirmed tool probing worked without issues.
  • Confirmed I could move all three axis(s) throughout their full range of motion without issue.

So in my case, it looked like the following happened:

  • During shipment, enough force was applied to the unit to cause the carriage to shift the screw rod in the stepper motor out of alignment. -_-;;;
  • Due to this, the end of the rod was no longer in place in the second bearing of the stepper motor, allowing the rod/rotor to shift and bind/lock.
  • The anti-backlash screw nut must have encountered some issues as well, as fully tightening it presented issues with strong binding again.

You need a few tools to take the thing apart as there are various sizes of hex socket head bolts and the philips screw heads on top of the stepper motor.

But right now, I’m a happy camper that the unit is working again, without having to dive any deeper into the guts of the machine. ^_^;;;

Figured I’d post my experience in case someone else runs into this same problem. At some point, I will need to think about replacing the motor/rod/nut as I’m sure it’s not an ideal state to be in.