Z axis gone mad!

Hi everyone I’m new to groups ! I have shapeoko pro and having z axis issues carbide already on the issue but still having same problem’s, the z freaks out out of control, they sent new z motor with no problem but still having issues. But I feel like the issue is the z axis wire in drag chain specifically the plug, I was wondering if anybody ever hardwired that motor to the wire in the drag chain? Thanks for all the help it will be appreciated.

Support should be able to address this.

What specifically happens?

Could you post photos showing how the Z-axis motor is connected to the wiring extension(s) and the extension to the controller?

Does the machine initialize as expected reliably?

It’s not letting me post video
Basically it jerks up and down like a glitch while running and can make it do by wiggling the z motor plug , it’s almost like the vibration of the machine is causing the plug connection inside to lose connection in the plug ,and it is getting warm so I’ve tried a couple things to limit how much the wires can move and it seems to be getting better but that plug is very loose , but I’m almost thinking about just hardwiring that connection right there and getting rid of the plug and see if that fixes my problem , because I have orders that I have to complete and I’m falling behind every day this isn’t running. Fleming already did video call and sent new assembly but still doing it.

I will defer to Fleming on this — please send the video in to support@carbide3d.com and we’ll do our best to work out how to handle this.

Mine is doing what you described, I sent a video to support about 15 minutes ago and just now found your post.

Hey thanks I too just sent video’s to support my plug connection is very loose ,I turned lights off a wiggle z motor plug and listened I could hear and see my plug arc and can here mine sparking and plug gets hot from it sparkling.

1 Like

I tried to post a video on here I just can’t make it work for some reason.

I uploaded to youtube to share, see if this is what yours is doing?
Z Axis Video, Possessed?

Exactly see if you can get it to do it again and then wiggle the plug like be kind of rough with it .

I guess I do have another question if somebody could answer it, the ground wire that is in the control panel where did everybody ground that to?

I just tried moving my plug while it was running, I didn’t get any change. I grounded mine right behind the controller.

Well I hope they can get you up and running pretty soon at least they have great customer service .

1 Like

Let me know what they tell ya and I’ll keep ya posted also thanks.

1 Like

I had the same problem with the Z stepper motor connection at the drag chain and yes I finally by passed the loose connection and hardwired it. The problem immediately was remedied. What I end up doing was clipping the connectors and stripping back the wires and soldered the corresponding wires. I also used heat tubing to protect the soldered connections. A very aggravating problem was immediately cured after that.

Later on I developed once again a similar problem with the x axis sensor connector. That time instead of hardwiring I took a straight pin and slightly cave in the female pin side of the connector. By doing this it gave me a good snug connection. That problem immediately was cured.

If I had to do it all again I would first try the straight pin method first. It was quick and easy. I hope this helps.

1 Like

Spoke to Fleming yesterday and we did some troubleshooting, they have sent a new cable as it appears the existing cable is bad. I should receive this tomorrow and I plan to install it when I get back home, I will provide an update.

1 Like

I had this exact same problem. I have 30 years of experience troubleshooting electronics and determined that the Z-motor side of the connector was at fault. I didn’t want to void my warranty by hardwiring it. I sent videos, etc. Carbide was real nice about it and sent me replacement cables for the Z Motor three times. They didn’t want to send me a new motor or Z-Axis assembly. On the 4th failure I went ahead and hard wired and heat-shrinked a new motor-side connector that I snipped off one of the sets of cables they sent.
No problems since.

1 Like

Same here z motor side was the issue , hard wire solder heatshrink and no more issues!

1 Like

I purchased a Shapeoko 4 and immediately experienced issues with limit switches not activating sporadically. Another issue is that some of the motor connectors to harness became hot - indicating poor electrical contact. On closer inspection the male pins inside the harness’ plastic connectors are too small for the metal females in the other connectors. The manufacturer has replaced the harness, but I’m still concerned that the new harness may have the same issue. I’ve asked C to look into it, but I’m still waiting for a response.

1 Like

I had z motor problems with bad connection plug got hot z axis would go crazy , you could see the wire arcing inside plug ,I hard wired it and all better now carbide will fix issues . There customer service was great from my experience.

Hey Jonesey, here a quick and cheap solution to your connectors issue. Xtension Connector Sets - OpenBuilds Part Store I moved the controller on my CNC and re-wired everything. In the process I replaced all connectors with those. Works great. Use the 4 pins for stepper motors.

Carbide3D should remedy to your problem, but in case things drag too long for you, you can use those easy to install connectors.