Z axis hits limit switch

if while the z motor drives the bit to Z=0.6 (inches), the z axis limit switch stops further z-axis movement, would that have any impact on a previously set z zero?

Using fusion and I see the code that raises the bit to z=0.6. I then see subsequent code that seems to move z in the negative direction to the correct depth, but, in reality, it’s starting the cut way too deep (by about 0.2 inches too deep).

Another symptom of the problem is that when the bit goes to retract height it just ever so barely misses the top of the stock (retract height set as model top + 0.2 inches)

1 Like

Do you have a G28 location set?

If not, G28 G91 Z0 may be maxing out your Z axis and causing it to lose steps.
Turn off G28 retracts or set a G28 location or use a different post processor.


i have not set a G28. Is there a default value?

MACHINE zero, on the homing switches.
If you want to keep using that post, with that setting enabled, just set a G28 position.
Jog to where you want that position to be, after homing, and send G28.1 to set it.

G28 G91 Z0 then tells the cutter to move to far right corner of the table at z=0? Correct? The X and Y don’t do that that I see. I do see the z motor drive to plus Z until the limit switch stops travel. (code line 19)

How do I turn off G28 retracts?


Another question I have is what is the utility of that line of code?

Never mind. found that answer on my own.

Not exactly. By specifying an “intermediate” position it only moves the specified axes.
G28 would move to the G28 position
G28 Z0 would move the Z axis only to it’s G28 position by way of Z0 (usually top of workpiece)
G28 G91 Z0 moves only the Z axis to is G28 position while first moving 0 units relative to its current position (effectively doesn’t move before going to G28, but you have to specify a motion to limit which axis moves).

Many post processors have it as a selectable option when you click post process.

The point is just to raise the Z.
I prefer using G53.

This topic was automatically closed after 10 days. New replies are no longer allowed.