Z Axis homing switch & Homing cycle Stopping


The first problem is that homing works sometimes but randomly does not complete homing and the pc stays on the homing machine screen in motion v3. Sometimes it completes Z and Y but doesn’t get all the way to the right before stopping. The Z offsets after homing but the Y homing switch stays pressed, so I can’t jut restart the software because it won’t start homing while the switch is pressed. I have to turn off the machine, manually pull it off the switch, then start the homing cycle.

The second problem I’m having is that when homing completes and everything seems right, I press Current Offset (Z + 6mm) and it comes crashing to the top. I mean the math makes sense to me -5 offset, press the button, tries to go +6 from that point which would be +1mm from the switch, which would put the Z crashing into the plate above it. I get why it would be crashing into it but I don’t understand why the switch isn’t stopping it from continuing up. Am I assuming wrong and the switch is not actually supposed to limit the Z movement or something?

The switches are actually used for homing only — you’d need another set plus shielded wires to actually use them for limit switches.

Early on folks were using soft limits which arguably earned a buy on the terminology, but that was found to be problematic and is now discouraged.

Please see: https://www.shapeoko.com/wiki/index.php/SO3_Function_Test#Distance_of_travel for a discussion of how much the machine backs off the homing switches and the various coordinate systems.

Just for reference, that command is really intended to bring the machine over the workpiece zero after you’ve set that.

1 Like

That makes much more sense.

Machines are pretty dumb, so to speak; it will do what you tell it to do, if you tell it to crash (and don’t have soft limits turned on) it will do so :-/

The gcode sender you are using is going to really affect your outcomes here. Carbide Motion for example has “soft limits” (big quotations there because its not GRBL soft limits, but software limits done inside CM) baked in to try and save you from yourself based on machine type. Have you run the initial “send config” with CM and set your machine type correctly?

The homing issues you have sound like a few things. First, if you’re on an XL or XXL, the stock homing feed’s are not fast enough out of the box and the machine “times out” trying to get home. Try powering off, moving the machine close to home but not on it, then power up, run a homing cycle.

Second, you may have bad homing switches… That would explain both the issues you have. Your machine and work offsets are not getting correctly set in CM.

Finally, make sure your GRBL version (.9 vs 1.1) and CM version (4.x vs 3.x) match up - .9 with CM3 and 1.1 with CM4.

1 Like

Is there any issue with turning the soft limits on? And that would be to send $20=1 to the machine, correct? I hate when my machine slams in to the top of the slider when it lifts to allow me to change the bit.

We do not recommend using soft limits — the logic is quite sensitive and may result in false positives.

Unless they are straight up limit switches and disable further movement in that direction, I’m not that interested. I’ll just have to be much more careful. I changed the X from 850 to 835 I think and that fixed the crashing to the left.

I have been manually putting the router near the switch limits before turning on and it doesn’t have an issue with homing. I think it was timing out. Thank you

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.