Z Axis Limit Switch always red

I’ve sent this to support as well via email:

I’m getting some homing issues. My Z axis limiter indicator is always red.
I’ve tried reseating the wires but I’m not having any luck. The red light won’t go off and my machine won’t home.
Any ideas that I might not have tried?

I’ve added some pics to my FB thread.

I appreciate any tips and help.

Hi and welcome to the forums!
Which machine do you have, Shapeoko 3, 4, Pro or HDM?

1 Like

Stephen, I am relatively new to CNC world, I’m hoping my two cents and some experience may help.
When I have first set up my Pro XXL, and powered up for the first time, I could not get the Z homing switch to stop illuminating red. I removed the sensor traced all the wires back to the board unplugged and reversed the operation hoping it may fix the issue. It didn’t.
What I remembered I had done while assembling the machine was to manually raise the Z axis up above its normal limit. All I then did was power off the machine, manually push down on the Z axis and router to lower the assembly, and power up the machine and initialize again. This time everything worked correctly.
If nothing else it’s worth a try.
Jeremy

I’m going to go out and give this a try. I appreciate the advice! It’s been running pretty good for almost 2 years, but now that I have some business it starts giving me trouble :).

Hello, sorry for the delay in replying. Machine started to work again now it’s back to acting up.

I have the 3xxl. Purchased in Nov 10, 2020