Z-Axis limit switch not working properly

Hi there,

i am new to the shapeoko4 xxl and after assembly i am not able to get past the initialization.

The z-axis moves to the top and it seems thet the limit switch wont stop it.

I tried the metal in “front of switch” and it lights up and on the board x-limit led lights up as well. Yet when i swap the extensins of x and z … it still is x that lights up. All switch LEDs light up:

for x and z → x lights up
for y → y lights up

In Carbide motion the z limt switch is not noted when the switch itself lights up.

Kind of clueless…did the error appear in the past ?


Hi @AlFa

From what you describe, it seems to me like this could be a wiring issue at the Z limit switch connector.

Can you take a close-up picture of the X and Z limit switch connectors at the controller level and upload it here ?

If both connectors have the three wires in the same “slots”, then this is a mis-wiring problem.

Make sure to contact support@carbide3d.com about this issue, they are you primary source of support and will follow-up.


Hi @Julien,

here is the image

I think that it is just what you described.

I purchased the machine via a retailer as i am from germany (because taxes and shipping). So i will wait for the reply from them before contacting carbide directly.

Can i change the wiring by myself?

Cheers Alexander

I would suspect that they won’t provide support themselves, I think you should get in touch with C3D support in parallel, no harm in that, they support machines regardless of what retail channel they went through.

Unfortunately, those connectors are not meant to be disassembled, pulling the wires from their slot will damage the barbs that hold them in place in the connector. However, I remember at least one case where support recommended to do it anyway: gently pulling the wires out, and pushing them back in the correct slots: it won’t be a robust/long term solution but it could be a workaround to have a working setup until correct replacement cables are shipped to you. I can’t tell you to do this myself though, I would prefer if you had feedback from support, for them to confirm that this is the right corrective action.

I’ll try and find this other thread I have in mind where someone had the same issue and temporarily fixed it this way.

1 Like

Thanks @Julien

i will contact C3D and let you know here what they say.

Kind regards

Just for your information if it comes to fixing the wiring yourself: the fix will be to pull out the black wire of the Z limit switch connector, that currently sits in the lower left slot marked “X” in the PCB silkscreen, and reinsert it in the top right slot marked “Z” (to the right of the red wire)

So it infact was a wiring issue of the z-limit switch connector (to board) combined with a loose cable in the z-limit switch connector (to extension) and followed by a yl-motor cable contact falsely installed. Thanks to @Julien

1 Like

Hi Alex,

My name is Matthias from Germany looking for someone sharing experience with EU resellers for Shapeoko. Could you support me on that? Thanks in advance! Matthias

Hi Matze,

yes i am from germany and i did buy my shapoko 4 xxl via a reseller from belgium. The name is fablabfactory and i was happy with them. They did a good job and the promised 3-5 days for transport were held. I can recommendd them so far.


1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.