Z axis limiter switch not working properly?

I was running a program wrong that had the machine thinking it needed to go above my material by about 3 inches. (that was my dumb and I fixed it without major issue) The thing that was weird was that the machine just tried to drive straight up through the limit switch, isn’t that kind of the point of having a limiter?

software said go too high, hardware tried to let it. shouldn’t hardware stop it?

all hardware and software are up to date as far as I know.
using Carbide create v7 and Carbide Motion.

The switches on these machines are actually homing switches, not limit switches. They are only used during the homing process.

There is a way to tell GRBL to use the homing switches as limit switches, but CM doesn’t take advantage of that capability. Plus, you only have homing switches at one end of each travel, so setting a ‘limit’ at the other end is just software.

1 Like

oooohhhhh. That is really good to know. Thank you. I hadn’t realized there was a difference there.
basically solves my “problem” then lol.