Z-Axis Loses Position during job run

So just got my XXL and am having issues with the Z-Axis not returning to current depth after retracting for move. Eventually the cutter is above the material and not cutting. When I pause, it tries to raise the cutter and it bottoms out on the z-Axis limit switch and makes a loud sound before stopping. When I assembled and tested the limit switches, they all seemed to work. But the issue is the increase z height in the middle of cutting that throws the depth off. If I run the gcode in a simulator, it all looks correct so I don’t think it is a gcode issue.

I want to make the suggestion that if you have unexplained Z axis problems (especially with the ZPlus) that you should make sure the linear bearings are moving freely. A couple of weeks ago, my Z started doing weird things just like described in this post. Then after one run, it wouldn’t move at all. I took out the screws holding the spindle plate to the linear bearings and found that I could not move one of them by hand. I removed the lubricating screw and added some lubricant, worked the bearing and eventually it became free and moved well.

1 Like

If it’s not something obvious, please contact us at support@carbide3d.com and we will do our best to assist.

I did open a ticket last night. Just waiting to hear from support.

From your explanation it may appear you are losing steps due to you running out of z axis height while running the program.

If your tool is touching the work surface how much z axis travel do you have before it bottoms out going up? And is your retract height in your setup a smaller number than this?

Also the limit switches are not for stopping the cut from going outside the boundaries. They are just for the initial homing of the machine. If your hearing the clunking noise your outside of the cutting parameters of the machine.


No, I am cutting 3/4" stock. There is plenty of space above for the z+ movement. The machine things it is lower that it is and when I pause it retracts all the way to the top thinking it has more room to go.

The pause button tells the GRBL controller to move to Zmax minus 5mm. If it retracts all the way to the top and does not stop 5mm before the limit switch (and keeps grinding once it hits the mechanical limit), this does mean that Z steps were lost before that, while plunging. What plunge rate and depth per pass are you using, in what material ? Which Z axis do you have (Z-plus?)

Also can you upload your gcode for a quick look, if possible?

I am using a #102 1/8" square endmill on a roughing toolpath. The plunge rate is 18 and and the feed rate is 60 at 18,000 RPM. depth per pass is .1. The material is pine. Not sure on which z axis I have. It would be the standard z axis that ships with the Pro XXL.

Here is the file gcode

I don’t know if it’s related to the issue you are experiencing, but ncviewer shows a bit of an odd plunge in your file here:


Thanks Gerry. I don’t think so. I noticed the Z axis being off around 5,000 line of the gcode.

Ironically it probably is good it is happening earlier… A hole punched in after 400,000 lines might be more heartbreaking :slight_smile:

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.