Z axis not setting the right zero

I’ve had the xxl for a few weeks and haven’t had any problems until now. My piece wasn’t cutting through. I changed the stock thickness. I assumed my caliper only goes to hundredths and perhaps the piece wasn’t completely flat. When I reloaded the file and set zero(using touch probe or manually) for the z axis, it’s off approximately .08 inch. I’ve recreated the toolpath and loaded the new file to Cm and it doesnt change. I restarted the machine and initialize it again. When I bring it to the center of the workpiece and lower it down it shows that the bit is sitting at 0 while touching the top of the workpiece. I checked the belts, the wheels, no play at all. It’s not hitting anything like the dustboot bristles or skipping on the belt.
Where do I go from here?
Oh, and it’s done this on 3 separate jobs now

When you are at Z=0 on top of the workpiece, if you jog upwards by say 1 inch, and use a tape measure to check how high it actually went, is it exactly 1 inch ?

also, 0.08" is exactly the height of the probe lip. Can you confirm you do not overhang the lip if probing Z only? I assume so since you say the issue occurs both with the probe and when zeroing manually, but just checking…

As best I can tell, if I lift 10mm it’s exact 10mm. The touch probe was sitting completely on the top. Lip and all.

maybe upload the G-code file for a quick check ? and the c2d file too.

HeartShapedBoxfile.c2d (1.6 MB)

Heartshapedboxcode.nc (63.8 KB)

The two don’t match (in the sense that, if I regenerate the toolpath from the c2d file, I get a different result from the g-code file you attached), it seems like in the g-code file you had Z zero set to “bottom” of stock (in the thickness menu):

while in the c2D file, you now have Z zero (properly) set to “top”, and the regenerated file looks right:

Any chance that when you adjusted stock thickness, you also fixed the setting from “bottom” (incorrect if you were zeroing off the top of the workpiece) to “top” (correct) ?

image

Can you re-generate the toolpath based on that c2d file you sent, rename to a different file name or something to be 100% sure it’s a new file, rerun and see if you still have the issue ?

2 Likes

Ok, that seemed to be the problem. When using the mouse wheel to scroll down to the ok button it will change the items in the drop down menu if you pass the cursor over them. Ive run into this issue before when I accidentally changed the machine away from xxl. I didn’t think to look at that as an issue. When I saved the new gcode I didn’t save the c2d file. That’s why they were different. sorry about that and thank you for your help. Problem solved.

1 Like