Z axis off about 50%

I have a shapeoko 3 XXL and the Z axis is off almost 50%.
Is there a method of moving a mm or so and then telling the program how far I am off? I have seen the Winston Moy Youtube where he recommends milling a “level” surface, but my depths never actually ever reach the programmed depth. This may not be the right approach but any suggestions are welcome. Cheers!

Here we go again…everyday, we deal with Z issues…and it seems that nobody does any research.

Have you checked to see it the pulley set screws are on the Stepper Motor shaft Flats?

1 Like

Movement along a given axis is controlled by several things:

  • No. of microsteps board is set for — should be 4x — check DIP switches if present (older board) — also check motor is NEMA23 if applicable
  • Grbl steps setting — this should start at 40 (for 8x)
  • mechanical — check pulley set screws and belt tension

see http://www.shapeoko.com/wiki/index.php/Operation_Troubleshooting and the balance of the wiki and docs.carbide3d.com

EDIT: Also, it’s hard to do research when one is starting out — there’re a lot of new concepts and terminology, and it’s hard to match up the generalized documentation w/ one’s specific perceptions of one’s specific difficulties — newcomers should be given the benefit of the doubt (and heaven knows, there’ve been a number of times when I’ve needed to have something which I ought to’ve understood re-explained). It’s a discussion forum, open to all, and we should accept that not everyone understands everything perfectly.


Yes I have checked the Pulley is attached to the flat of the shaft, and I also checked the tension as well as watching it during run to ensure there was no skipping…

Another concern — perhaps the belt is too long? (this would fall under belt tension above)

Send an email to support@carbide3d.com

We will need some information.
Is this a new machine?

What are your machine settings?
Type $$ on the MDI line with a log window open.
specifically you need to look at:

Looks like $102 is set to 20. Mine is set to 40, so that would account for half…

Your settings for max travel look way to small too.
$130 and $131 should both be max 850 mm for an XXL.

Mine are set to
$130=800.100 (x max travel, mm)
$131=838.000 (y max travel, mm)

$102 is the culprit. It should be 40 not 20.

If you want your machine to be accurate, you’ll need to calibrate $100,$101, and $102 for belt stretch/tension. Unfortunately the document explaining how to do that has been removed from the Carbide 3d site (I just looked for it and it is gone).

Basically, the default guesstimate is 40 steps per mm for all three axes. In reality your machine will vary a little, so you have to measure how far it actually goes when you tell it to move a set distance; then you adjust $100,$101,$102 to calibrate the movements to be more accurate.

My machine is typically “off” by 1/32 of an inch per foot or so in X and Y after snugging up the belts, etc. So it isn’t like it will be way off if you just leave all three at 40. If you are just trying to get things working and learn how things work you can probably wait and calibrate after you’ve done some test projects and gotten comfortable with the machine.

But that Z has to be 40-ish not 20. That’s why you are getting half the distance you expect in Z.

1 Like

Thanks for all of your help. I made the change to 40 and all is right with the world now. This is weird that it is off like that. This is the stock program that came with my machine when I got it.

1 Like

I found this to be a great resource:

I think it is worth spending some time with the log window open sending commands manually to the machine using the MDI, with the router turned off. Your machine can be commanded “manually” – for
example I’ve used MDI commands to run undercut router bits through stock, not the sort of thing which can be done easily using CAD/CAM at least with this class of machine and software.

1 Like

Good eye @mpfreivald WINNER!

$102 needs to be same as the others.

Type $$102=40 and move the Z to confirm you are indeed moving 1mm when using the 1mm jog in Carbide Motion