Z axis too high

Hi all, I am brand new to the cnc world. As such I am having some trouble with my shapeoko 3. I am trying to carve a shallow pocket in some pine. I have measured the material at .740" . I used that number for material thickness. My issue is when I go into CarbideMotion the machine seems to do almost everything right, but about 1\8" above the surface of the board. Any idea what i might be doing wrong?

Usually this is a problem in how one homes: http://docs.carbide3d.com/tutorials/tutorial-homing/ — if that doesn’t help, post your files and a step-by-step description of how you clamp the stock in the machine and set zero relative to the stock.

Thanks for the advice Will. I home the machine to back right. The pull off is set to 5mm. I place my material, a 16" square pine board. This is clamped in place with 2 bar clamps at the front, snug but not real tight. I also have 2 screws at the back of the board. I then jig the machine to the front right of the board. I zero x,y axis. Then zero z-axis to tip of material using sheet of paper for minimal clearance.

Not sure how to post the files. I’ll see if i can figure it out.

this is the upload button,you will see it when you hit reply

1 Like

Here is the sign I am trying to make. It is for SIL and her husband for around their pool
Palm tree sign.c2d (1.6 MB)

Thanks for the help, it is really appreciated.

Looking at the file, you set X and Y zero to the lower left corner, and Z zero at the top of the material. Did you zero Z to the top of the material (ie. move the bit to contact with the top, then zero Z in carbide motion?)

Yep, zeroed z-axis right before running the program. Usef a piece of paper to set zero at about .002 above the surface of the board.

Didn’t change bits after setting Z zero did you?

Nope, but i did run the portion of the program with the trees on a scrap board. Did everything the same, same settings, but with a 1\4" end mill and everything worked perfect. Changed bits to a 1\16" ball mill, all settings exactly the same, but with the smaller bit it runs too high. The 1\4 end mill cut almost 1\2" deep into the scrap, in three passes.

Also ran this program a couple of days ago with the 1\16 ball but had it set to Texture not Contour, in the tool path tab and everything worked perfectly.

Can you set your zero, jog up 50mm, and then send G1 Z0 F500 (send the cutter to Z zero)?

You need to reset your Z Zero when you change bits. When you zero your Z you’re telling the machine where the very tip of your bit is. When you change bits this position changes. So your machine still thinks the tip of your 1/16th ball mill is in the exact position that the tip of your 1/4" end mill was. But in reality it has changed - it’s sitting higher (it’s a shorter bit/its pushed further into the collett etc). Hence it’s cutting the air above your work piece.

Carbide motion will prompt you to change bits as required as it moves from one toolpath to the other - but it will not prompt you to re-zero your Z. My preference it to separate the job into separate jobs. Run a single job with your 1/4" endmill and let it complete. Switch the machine off, change bits the start up again. It will re-initialise and then you can use the rapid position function to return to the X/Y offset you used on the previous job and it will let you re-zero the Z axis only.


OK I will ensure I do this this evening. I am at work right now and everything is off in my shop at home. I know that I have the 1/16 bit that I will need, in the spindle, so there won’t be any bit changes to foul things up. I will jog the machine from its home position to the start position at lower left. Set X-0, Y-0 and Z-0 at that point to see how it works. According to what I have read and seen on Youtube, this is what I should be doing. Correct?

1 Like

Hey Dan, if everything is exactly as you left it when the 1/16th ball was cutting too high (workpiece still secure in exact same place etc) then you don’t want to rezero x and y, just z.

1 Like

I think I will Travis since CM requests me to home the machine every time I re-connect to the cutter. I then have to jog the machine to the starting point from home position.

The software remembers your x,y and z from the previous job - regardless of whether the machine was turned off or rehomed Dan.

So now you’ll switch your machine on, it will initialize and find home as it does each time and then you can start. When you are on the page in Carbide Motion where you jog your machine - instead of moving it manually to where you think X and Y is, press the “Rapid Position” button. When you do a page will pop open with an option “Current Offset (X & Y)”. Press this and it will return to the X and Y zero position you previously set. You then manually set the new Z Zero with your new bit and run the job. http://docs.carbide3d.com/assembly/carbidemotion/userguide/


Hey Travis,

Sorry for the lengthy response time, but I was working at my “real job”.

I followed your instructions and read through the link you provided. The bit us closer, but still about 2mm above the surface.

I also noticed that when I use the rapid move button the machine does go to the actual starting point. It is close, but I still have to adjust the machine to get to the starting zero.

Any other ideas on what I might be doing wrong.

The machine knows where you set zero, you should -never- have to “jog the machine to the starting point” from the home position. This makes me think you’re not actually setting WCS zero correctly.

1 Like

If you aren’t returning to your exact original ZERO’d point after homing and then Rapid Positioning back, it sounds like your machine is missing/skipping some steps. This is usually manifested in your belts not being tight enough, or the set screw on one (or more) of your motors is loose.

Thanks Adam. I know the machine is only a couple of weeks old, but something might have been missed during assembly. I’ll check these today.

I think I figured out my issue. I don’t believe it was the programming, how I was setting up the machine. I had noticed on another program that the left side did not cut as deep as the right side. Even after I squared the machine.

I made a supplemental waste board and milled about 3/8" off to give me a flat true surface. Retried the program with the thickness of the waste board and the work piece, as measured, and seems to work good now.

1 Like