Z Axis Zero/Probe/Bit Setter Issue

Hey gang, been a little while since i’ve been here but i’m running into an issue.
I design my projects in carbide create, double and triple checking all my details (material thickness, cut depths and all that), then i save my gcode file.
Over in carbide motion i use the touch probe with the standard 1/4" end mill to get my zeroes, then i load the file i want to run. It prompts me to insert whatever cutter and i do it, and the machine proceeds over to the bit setter, pushes the button all the way down, comes up, then down and pushes the button a little and comes back up, then proceeds back to the front center and prompts me to turn on the spindle.
I turn on the spindle and click resume, and then it moves to the starting position but pretty much every single time it plunges too deep and i immediately hit the pause button, power off the spindle and stop the job.
I jog the spindle to the Z axis +6mm location and quite often it lands 3mm above the material surface. What?!? So i then manually zero the Z axis using the technique where you put a piece of paper between the material and tip of the bit. I check the Z axis +6mm again and it’s fine so i proceed to run the job again. It goes over and plunges to do its thing at the bit setter, comes back and when it plunges to start cutting, it might be correct but sometimes now it doesn’t plunge deep enough and starts cutting the air about a half inch from the material! When i stop the job and check the Z +6mm again now it’s way high! it usually
takes me 3 attempts to get the Z axis zero correct.
Correct me if i’m wrong but Isn’t the purpose of the Bit Setter to determine the depth the bit is mounted in the spindle whenever you change bits? and then it should calculate that with the information from the touch probe so that it knows right where the Z zero point?
Anyway, i’m confused and a bit frustrated. I’m using the latest version the software and i keep running into this problem. I feel like the bit setter isn’t doing anything. Can anybody shine some light of this for me? Thanks so much!


Sounds pretty thorough. The only thing you appear to be missing or aren’t describing is when your probe bit is measured by the bitsetter.

You need to have the bitsetter touched twice. Once before you zero Y, and once when the jobs bit is asked for.

1 Like

Before this happens, have you seen the “initializing” sequence? Usually, this happens when you turn the machine on and a yellow button is there. The router initializes XYZ in the top right corner. THEN IT COMES TO THE FRONT CENTER FOR “A PROBE” AND DOES THE FIRST BITSETTER OPERATION.

1 Like

A ~3mm discrepancy in Z-axis zero is usually caused by positioning the probe so as to probe in one way, but probing in the other.

If that’s not it, post a .c2d file, generated G-Code, step-by-step notes on how you are securing your stock and setting zero relative to it, and a photo showing an attempt at cutting still in place and we’ll do our best to work through this with you.

1 Like

The ‘plunging too deep’ was happening to my job this morning, and I couldn’t work out why - until I checked the ‘Zero Height’ in the Job Setup screen and, for some reason, this had changed to the Zero Height being at the bottom! I’ve never run a job with this setting before, so I’m not sure why it happened today!

I think this is as important as your 3mm discrepancy, but nobody seems to have noticed that bit!

Sorry, guys :slight_smile:

1 Like

Yes, when i turn on the machine in the first place i “connect to cutter”, and then i “initialize machine”, so it runs itself to the back right corner, comes to the front center and tells me to insert a bit (which i do), then it goes over and plunges twice on the bit setter and comes back to front.
Then i put the touch probe on the front left corner, connect the little alligator clip to the bit and run the probe xyz with the 1/4" bit. It does its thing.
Then i load the file and run it and then first thing it tells me is to put in the bit required, which i do, then it goes over and does the double plunge at the bit setter, comes back, i turn on the spindle and away we go.

Yeah, connect to cutter, initialize machine. I do that👍🏻

Thanks Will. My touch probe IS fully registered on the corner of the workpiece. Just to confirm that i know how the probe works…when the bit touches the probe and the light turns red, it’s compensating for the thickness of the probe itself to get the zero point, is that correct?

With the problem i’m having, everything does seem to zero properly when probing. So it makes me think something is happening to the Z zero between the time i say “start job” and the second plunge to the bit setter.

I’ll also get the files and pics you asked for and post them here but i can’t do it for a few days due to christmas travel. Thanks again Will!


Did you ever get this issue resolved? I was having the exact same issue, but not every time. Sometimes it would work on the first try, but the rest of the time it was on the second attempt after I scrapped out the piece that I was working with. Now I am gun shy and stop the program after the spindle sequence just to double check the Z height.
My twist is this though, today the 60° bit that I was using was 15mm above the part when it was supposed to be Z 0 +6mm. I ran it through initialization and then worked through the steps 3 times and finally did it manually with no issues. Please let me know if you figured out what was happening as it would save me a lot of time.

Thank you!!

1 Like

One thing that others have done when we hear about this particular problem, is not mention that they click the “zero all” button at some point while they are zeroing XYZ.

Don’t do that on purpose or accidentally (carefully read the label) while using the BitSetter.


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.