Z fail diagnosis?

I have a new one. Just used the machine yesterday. Today I went to redo a sign and everything is fine in X & Z, but every time I try to move the Z-plus carriage with software the I get a screaming noise like Z is blocked. I can move z manually (fingers on link at top). When I trigger Z via software the stepper starts to move but behaves like its blocked and it screams until I cut the power.

I don’t see any physical blockage. Blown driver? Bad stepper motor? Something not visible that can block Z movement?

Anybody seen this?

I pulled the Z stepper and it behaves the same completely out of the carriage. You click on Z and it makes a screaming noise and doesn’t move.

I assume the stepper motor isn’t repairable?

Can you check that all of the wire crimps are seated properly in the connector? possibly it’s just not driving the phases well because of a wiring issue.

What setting do you have for $102? (steps/mm for Z-axis)

This is still uses the old Sparkfun controller so all the joints are soldered and taped/shrink wrapped. The terminal connections on the controller board end look fine.

Worked fine yesterday and I homed the machine and left if idle overnight. This AM not working.

So the solder joint is interesting, if not an issue on a driver it would not be unheard of for a solder joint to fail overnight. Less likely for something like a bearing especially if you haven’t heard squealing before.

Try powering down, leaving it for a bit, then swapping the controllers to drive a known good motor from that stepper driver? If that doesn’t work, probably the stepper driver has failed.

Ok I swapped the X and Z and the problem moved to the X so its clearly the old Stepoko controller which I am pretty sure is discontinued (Sparkfun barely supported it even back when it was new).

Will generously supplied me with a controller and harness which I now need to actually use. Looking over the situation I need help with the following:

  1. The Carbide controller appears to use some proprietary power connector and I am unclear where I would get a power supply. The Sparkfun just uses a high wattage 24V supply with standard connector.

  2. The wiring harness expects 4 pin female molex connectors. I tried to look them up on Digikey but couldn’t find them (I have crimpers). How do I acquire these (yes I could cut them off and solder but that’s not cool).

  3. The sparkfun controller mounts on the left Y bar. I think the Carbide controller mounts on X using pre-tapped holes. Any idea how I mount this thing? Is the controller in different places based on the model?

My machine is a bastard with Sparkfun controller and several Carbide upgrades for limit switches, XXL bed extension and HDZ.

1 Like

Is using the Gradus M1 Pro I sent not an option?

Yes but I’d like to move in the direction of stock Carbide. I think I have that other controller around.

None of these are insurmountable. The power supply is the hardest. Surprised there’s no mod to use a more standard power connector.

Just to correct the record, in reading the XXL wiring instructions I think the harness and controller came with the XXL upgrade and was never installed because at the time I didn’t want to deal with swapping out the Sparkfun.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.