Z height not persistent...seems random

I am not sure if this is an issue with carbide create (build 764 pro) or shapeoko (5 pro).
I am using bitsetter v2.

Order of operations to carve:

  • load file
  • use bitsetter and probe for x, y, z
  • start cut
  • load new bit
  • machine measures bit on right-side bitsetter
  • watch bit move to position and then plunge through the workpiece and table while I scramble for the stop button OR watch the bit spin ~5" above the project.
    (I have diligently confirmed depths in carbide create)

The only way I can carve is to load everything, reset Z again via a piece of paper, and hope. Sometimes, when changing bits, the Z axis is reset to well below where it was (up to an inch).


  • I have tried loading the file before and after setting 0’s.
  • For the bitsetter v2, I have tried using the bit I am starting with and the inserts that come with it.
  • I have removed, forgotten, disabled, and re-added the Shapeoko’s bitsetter on the front right corner several times.
  • It doesn’t appear the Z axis is slipping when it is paused although when power is cut, the VFD does slide down ~2"s. Perhaps this is pushing power back to the board? The weight was held for the month I’ve had it so this slippage is something new as of a few days ago with no other changes.

I’m doing detailed inlays and can’t stretch out my vectors or add many more plugs before the idea of a clean piece is completely lost. More importantly, I’d like the convenience of the bit setter and bit setter v2 to operate as expected. As is, I have no confidence in the machine without double-checking it, and even then it may or may not function.

Has anyone had their z-axis go rogue? Any other troubleshooting ideas to fix the root cause?

It’s almost certainly a workflow problem, which probably means you’re new to Shapeoko, so you might want to try the beta release, which changes (simplifies?) the BitSetter workflow so it’s a lot harder to go wrong. You can learn more here:


Thank you. I appreciate the quick response.

I am confused by the fact I have done several cuts without issue (>75) and this is new. After setting all zeros using bitsetter, loading a bit, then waiting for the machine to measure it, the z axis is off by 1 - 3 inches - even when I don’t put a new bit in. This seems outside the scope of operation order.

It also seems odd the z-axis drops slightly now when power is cut. After I restart and rapid to z = .6, the bit is almost always stopped by the material.

I’ll try out the beta - the workflow seems more straightforward and efficient which I look forward to. If there is something I can do to test the motor or shouldn’t see the drop when cutting power, I would appreciate any thoughts.

The best way to test the motors and functioning/adjustment of the machine is to load a 1/4" probing pin, power up, jog the machine to the center of each axis, then with the power still on, grab the tip of the probing pin and try to use it as a lever to move the machine in each axis — there shouldn’t be any motion, and the machine should be rock-solid — any motion which occurs should be investigated so as to determine and address the cause.


Thank you - I’ll give it and the beta a try.

I’ve heard that over and over. It’s your workflow.
I wasted a $110.00 swamp ash guitar body blank today with that same issue.
1- Boot windows computer.
2- Start CM
3- Turn on controller
4- Connect to machine
5- Initialize machine
6- Zero XYZ with Bit Zero
7- Load program
8- Install cutter
10- Set with Bit Setter
11- Run first program file- works as expected
11.5- ??
12- Load second program file
13- Install different cutter bit as directed by CM 622
14- Set with Bit Setter
15- Start program file- bit plunges into body blank
I verified programs are working good by adding step -11.5
The only way I can stop this from happening is to shut down the controller and CM 622 between tool changes. Basically, start over.
Is that supposed to be part of my workflow? Step 11.5 ? - Shut down-Start Over
Seem to be more of a software or firmware problem to me.

It’s almost certainly not a software issue. We’ve been through this with people and nobody can make it happen when we’re on a video chat walking them through it.

Give that beta a shot. The only bug we still have to deal with is a problem with the BitZero V1 probing. Otherwise, it looks stable in all of our testing and it flips the workflow around so it’s almost impossible to put a tool in at the wrong time.


I have BitZero V2, CM build 622.
Workflow details listed step by step.
Please point out what steps in my workflow need to be changed.

I think you might need to have a video chat with C3D rather than a forum one. Best way to deal with it. Yes you’re out one blank and that does affect your bottom line but I’m sure they’d be happy to help you with whatever could be going on.


@robgrz - I unplugged everything for a while, built new carbide create files to start fresh, installed the beta, and made two successful carves without issue (MDF). I am saving my victory dance until I’ve done a few actual pieces with older build files. That will help narrow things down as well if z-axis issues persist.

It is worth highlighting the efficiencies in the new beta. The lack of bitsetter during initialization reduces unnecessary movement and using bitsetter v2 feels much faster with the speedruns while checking x/y. Individually, the optimizations may seem small but together, certainly have an impact. I’m happy to see Carbide addresses the smaller items - it shows organization/product maturity when you can address user experience as well as key functions vs consistently chasing tech debt.



I’m glad it comes through. About a third of the development time for this build was chasing little sub-second delays to see if they could be eliminated. I don’t run the machines a lot, but it felt faster to me, and I was hoping that it wasn’t an imaginary benefit that I talked myself into.


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.